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Getting Started
Introducing VAST

VIVOTEK offers the most comprehensive central management software VAST V1�5, designed 
for managing all VIVOTEK IP surveillance products with intuitive functions and numerous fea-
tures�
It supports an unlimited number of cameras and stations in a hierarchical structure of system for 
monitoring, recording, playback, and event trigger management with ease-of-use and efficient 
control�
Most particularly, the newest fully scalable feature VAST Matrix offers an unlimited number of 
live views for monitoring; with simultaneously 16-channel playback facilitating quick & easy 
browsing from multiple stations� It performs remote management with a large scale of the server 
& client structure and constitutes a robust system for stores, banking, and public space�

Special Features

  Powerful Video Wall Solution “VAST Matrix” for Unlimited Live Views*
  Intelligent PiP Function -- Digital Zoom In and Multi-touch Mode
  Integrated with VIVOTEK NVR for Extreme Applications
  Convenient Remote Access via Client/Server Architecture
  Powerful Hierarchical Management for Unlimited Stations*
  Effective & Reliable Event Trigger Management
  Real-time 64-channel Live Viewing and Simultaneous 16-channel Playback
  Multiple Simultaneous Streams for Different Media Platforms
  Activity Adaptive Streaming for Dramatically Reducing Bandwidth and Storage Space
  Synchronous/ Asynchronous Playback for Effortless Viewing
  Extremely Versatile Settings for Recording Storage and Recording Schedule Management
  Role-based User Management to Enhance Security Operations
  Efficient Data Backup, Search, and Export
  Intelligent PTZ/ E-PTZ Remote Camera Control
  Overall Device Management through Intuitive E-map Feature
  Instantly Playback Event Recording
  Supports Web Access via IE and FireFox
  Built-in Instant Player for Playback
  Supports Post-Video Enhancement and Defog
  Accessible through NAT Using the Public IP
  Supports Two Way Audio

* The number of linked devices will depend on the license on the key dongle�

* The ability to extend devices is also subject to the network bandwidth and computer performance�



 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
2 - User's Manual

 

 

VAST Server and Client Components

There are four components in VAST: one server component--VAST Server, three client 
components--VAST LiveClient, VAST Playback, and VAST Matrix�

VAST Server provides a centralized management site for video recording� VAST LiveClient 
is a client program for the user to login and modify the server's configuration, edit the server's 
recording storage, schedules and many other functions on the server; VAST Playback is 
another client program for the user to login and browse the recorded video database and video 
clips related to specific events on the server.

Usage Scenario
The powerful management scalability of VAST makes it suitable for managing from the small-
scale to the large-scale structures�

For user that only manages a few cameras, we recommend installing the client and server 
components on the same computer� A host with all of the three components installed is recognized 
as a stand-alone site� All the functions can be simultaneously performed on one single site� 

For user to manage large-scale surveillance systems, please plan the hierarchical structure first. 
Then you can start to add cameras to each station and connect these sub-stations to the root 
station� The whole hierarchical management system is thus constructed�
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Technical Specifications

VAST Server Functionality

  Centralized management site for all the logged in clients
  Maintain the configuration of the hierarchical management list
  Unlimited video recording channels
  Store recorded data onto multiple hard/network disks
  Live video for the local/remote LiveClient users
  Recorded video for the local/remote Playback users
  Zero latency database recovery

To configure the server, you should use VAST LiveClient to log in. The convenient and intuitive 
user interface in VAST LiveClient will enable you to edit the settings of the target server�

Technical Specifications

Hierarchical Station Management Architecture

Ver 0.6

VIVOTEK INC.
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Architecture
．System: Client/Server
．Remote client: Yes
．Web access: Windows IE6, IE7, IE8, FireFox 3�5 
．Hierarchical: Yes
．Program: LiveClient, Playback

Protocol
．Client/Server communication protocol: HTTP tunnel with XML content
．Encryption between Client/Server: Encrypt with AES

Playback
．Max channel number: 16
．Type: Asynchronous, Synchronous 
．Event search: Yes
．Mount local database

Video Enhancement
．Post-video adjustment: Brightness, Contrast, Saturation, Hue
．Video enhancement: Fog, Rain, Snow, Fire/Smoke

Event Management
．Live event awareness: Yes (Display in the event window)
．Trigger sources: Motion, Tampering, DI/O, PIR, IVA, and Temperature
．Actions: Email, Start to record, Move to preset location, Set DO, GSM 

short message, Send CGI command

Other
．Camera configuration: Web-based configuration page embedded in 

LiveClient for all functions
．Multi-lingual user interface: Nine preset languages, additional 

customized languages
(English, French, German, Italian, Spanish, Traditional Chinese, 
Simplified Chinese, Japanese, Portugal)

．PTZ control: Joystick support, Click on Image, PTZ panel, 
Keyboard shortcut

．Supports E-Map
．Supports all VIVOTEK Network Camera
．Supports two way audio

General
．Max channel: Unlimited
．Max channel per hard disk: 32 channels
．Max frame rates per second (per hard disk): 960 (32ch x 30 fps,VGA)
．OS:

Windows 7 Professional
Windows XP Professional
Windows Server 2003 
Windows Vista Business

．Supported DBMS: SQL server, PostgreSQL
Depend on H/W spec

Codec
．Video compression: MPEG-4, MJPEG, H�264 
．Audio compression: AAC, GAMR, G�7221, G�729A, G711, G711A

Recording
．Recording types: Manual, Scheduled, Event trigger
．Event trigger sources: Motion, Tampering, DI/O, PIR, IVA, and 

Temperature
．Multiple hard-disks: Yes (Each group can utilize several disks) 
．NAS/SMB: Yes
．Media file format: ISO base media file format
．Cyclic recording: Day based, Spatial based

Security
．Authentication system: Private account with password
．Account role type: 5 levels of user roles

Exporting
．Exporting format: AVI, EXE, 3GP
．Snapshot format: BMP, JPEG
．Source: Live view and media files

Backup
．Backup types: Manual, Scheduled

Layout-live
．Layout types: 1x1, 2x2, 1+5, 3x3, 1+12, 4x4, 5x5, 1+31
．Drag & Drop: Yes
．Layout sets: Yes (Switch between different layout sets)
．Automatically add a newly-inserted device to the layout: Yes

All specifications are subject to change without notice. Copyright    2010 VIVOTEK INC. All rights reserved.c

Client Client

Internet

InternetInternet

Internet

Internet

VAST Server

VAST
Server

VAST
Server
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VAST LiveClient Functionality

  Server function control
      Hierarchical station management
      User account management
      Recording storage management
      Recording schedule management
      Recorded data backup
      Event trigger management
  Flexible video live view layout
      Dual screens for maximum 32 channels simultaneous monitoring
      1x1, 2x2, 1+5, 3x3, 1+12, 4x4, 5x5, 1+31 monitoring layouts
      Multiple video viewing pages
  Virtual Matrix for video wall display
  Intelligent PiP function
  E-map for overall management
  Network storage for recorded video
  Convenient switching among multiple monitors
  PTZ / E-PTZ operation panel for camera control
  Support two way audio
  Instant playback for event recording
  Support joystick control
  Remote configuration for network cameras
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VAST Playback Functionality

  Browse the database of recorded video from the server
  Flexible video playback layout
      Maximum 16 channels simultaneous playback
      1x1, 2x2, 1+5, 3x3, 1+12, 4x4 video playback layouts
  Support powerful playback functions
      1/8x, 1/4x, 1/2x slow-down playback
      2x, 4x, 8x, 16x, 32x, 64x video playback speed
  Intelligent PiP function
  Support convenient evidence and data exporting
      Export media files of recorded video
      Support snapshot and print out
  Support convenient switching among multiple monitors 
  Search engine
      Time search
      Event search
      Log search
  Playback while recording
  Support synchronous/ asynchronous playback
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Minimum System Requirements
Before installing the VAST software, please make sure your system meets the following 
recommended minimum system requirements�
If you would like to install ST7501 Server only, please follow the requirements as below:

If you would like to install both the server and client programs, please follow the requirements as 
below:

  Only users with Administrator privileges can install or use VAST on a Windows Vista system�
  The required hard disk space will depend on the video settings, the number of network cameras and recording 

group settings� Please add more hard disks if you want to extend the system� 
   *32-CH, VGA, about 1 week recording: 750 GB
    64-CH, VGA, about 1 week recording: 1TB x 2
    32-CH, 2-megapixel, about 1 week recording: 2TB x 2
    64-CH, 2-megapixel, about 1 week recording: 2TB x 4

Server
Operating System Windows Server 2000, 2003, 2008 / Windows XP Professional (32 and 64 bit), 

Windows Vista Business (32 and 64 bit), Windows 7 (32 and 64 bit)
Channels Below 32 channels Above 32 channels

CPU Core 2 Duo E6400
2�13GHz or above

Core 2 Quad Q6600
2�4GHz or above

RAM 2 GB or above 3GB or above
Network Interface Card Ethernet, 1 Gbit recommended
Graphics Adapter AGP or PCI-Express, minimum 1024×768, 16 bit colors
Hard Disk Type ATA-100, SATA, SCSI, SAS (7200 rpm or faster) in NTFS format
Hard Disk Space 750 GB free *

LiveClient and Playback

Operating System Windows Server 2000, 2003, 2008 / Windows XP Professional (32 and 64 bit), 
Windows Vista Business (32 and 64 bit), Windows 7 (32 and 64 bit)

Channels Below 16 channels 16 ~ 32 channels 32 ~ 40 channels Above 40 channels

CPU Core 2 Duo E6400
2�13GHz or above

Core 2 Duo E8600
3�33GHz or above

Core 2 Quad Q6600
2�4GHz or above Core i7

RAM 2 GB or above 3GB or above 4GB or above
Network Interface Card Ethernet, 1Gbit recommended

Graphics Adapter AGP or PCI-Express, minimum 1024×768, 16 bit colors
Minimum 128MB Video RAM, 512MB recommended

Hard Disk Type ATA-100, SATA, SCSI, SAS (7200 rpm or faster) in NTFS format
Hard Disk Space 750 GB free *
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VAST Installation
Installing the VAST Software

1� Run VAST_Setup.exe on your computer� Click I ACCEPT the License Agreement and specify a 
location to install the program�

2� Select the items you want to install, then click Next to continue�
 If you want to install both VAST Server component and Client components, please follow the steps 

below to install the database�

3� Assign a username and password for the VAST Server and click Next to continue�

Please record the username and password for login later�

Server component
Client components
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4� Install a database on your server� There are two options--PostgreSQL (8�2 version or above) or SQL 
server (2005 express version or above)� In order to avoid conflicts among different databases, we 
suggest you remove the original database from your host� Then follow the instruction below to install 
PostgreSQL or SQL server�

PostgreSQL
Please note that PostgreSQL may interrupt an antivirus program. 
Follow the steps below to install PostgreSQL Server:
a� Select PostgreSQL from the drop-down list and assign a password� VAST server will by default store 

the recorded media file under c:\Recording. Click Browse  to change the path if you plan to store 
the data under another path� Then click Next to continue�

b� If you do not have PostgreSQL, select the first option to begin the installation� If you already have 
PostgreSQL installed on your host, select the second option to enter the related information�  

c� Wait for the installation process to complete, then click Close to exit the installation program�
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SQL Server

Follow the steps below to install SQL Server:
a� Select SQL Server from the drop-down list and assign a password� VAST server will by default store 

the recorded media file under c:\Recording. Click Browse  to change the path if you plan to store 
the data under another path� Then click Next to continue�

b� If you do not have SQL server, select the first option to begin the installation� If you already have 
SQL server installed on your host, select Windows authentification or SQL Server authentification� 
(Username and Password may be necessary according to the settings when you install the SQL 
server�) Click Install to begin the installation�

c� Wait for the installation process to complete, then click Close to exit the installation program�

Once you have created a user account for a VAST station, you can login to VAST Server from any computer over 
the network through LiveClient and Playback�
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VAST Server
Activating the VAST Server

VAST Server is a service program that will run automatically when the computer starts up� Or 
the user can unselect the option of Auto launch at windows startup on the VAST Service Control 
program tray icon in the tool bar�

How to Configure the Server

Please follow the steps below to configure the VAST Server:
1� Find a local/remote computer that has installed VAST LiveClient�
2� Activate VAST LiveClient and login to the target VAST Server�
3. Configure the server using the VAST LiveClient user interface.

How to Stop/Reboot the Server

Please follow the steps below to stop/reboot the server:
1� Click on the VAST Service Control program tray icon  in the toolbar�
2� There are 3 options Start/Stop/Restart service for the user to choose� It’s selectable by right-click on 

the Service Control program tray icon�
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VAST LiveClient Configuration
Activating the VAST LiveClient and Logging in to a VAST Server

VAST LiveClient allows you to monitor live video from cameras managed by the VAST Server; it 
is also the main user interface for server function control� 

After installing the VAST LiveClient program, please follow the steps below to activate VAST 
LiveClient:
1� Run the VAST LiveClient program�
2� A Login window will pop up� Enter the information as shown below:
  If you want to login to a remote VAST Server, enter the IP Address, User Name, Password and the 

Communication Port of the target server correctly� Click Login to log in to the target server�
 If you want to login to a local host that is running VAST Server, check the Login local station check-

box, then the local IP Address will be displayed automatically� Enter the User Name, Password,  
and Communication Port of the local server for login� Click Login to login to the target server�

 

3� The VAST LiveClient monitoring window will pop up�

  If your network environment need to set up proxy, click More >>  to extend the login window, then click Proxy 
Settings  to open the dialog� Then enter related information to link to your proxy server�

  Available functions of the VAST LiveClient program will be enabled according to the role of your login account� 
For more details about the privileges of the user account, please refer to How to Manage User Accounts  on 
page 44�
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VAST LiveClient User Interface

Menu Bar

Status Panel

E

C
B

G

A

D

User Name
Station Name (IP Address)
Login Time (yyyy-mm-dd hh:mm:ss)
Current Time (yyyy-mm-dd hh:mm:ss)

Menu Item Drop-down Options

System Lock / Enable Click On Image (Disable Click On Image) / Language / Second View / E-map / 
Launch Playback / Logout / Exit

Edit Manually Begin Recording (Stop Manual Recording) / Snapshot / Print / Record to EXE (3GP, 
AVI) / Snapshot Zoomed Image / Print Zoomed Image / Find

View PTZ Panel / Two Way Audio Panel / Instant Playback Panel / Event Window / Full Screen / 
Minimize

Configuration

Camera Management (Insert Camera / Update Camera / Delete Cameras / Batch Insert 
Cameras) / Station Management / User Management / Association Management / Event 
Management / Virtual Matrix Management (Matrix Management / Matrix View Settings) / 
Station Settings (General Settings / Network Settings / Recording Storage Settings / Recording 
Schedule Settings / Scheduled Backup Settings / Server Settings / Relay Settings) / Client 
Settings (Snapshot Settings / Recording Settings / View Settings / General Settings / Joystick 
Settings / Proxy Settings / PiP Settings) / Video Enhancement (Basic Image Adjustment / 
Defog)

Layout Start Rotation (Stop Rotating) / Edit / Choose

Help About /  License

A� Menu bar                 B� Quick access bar                C� Hierarchical management tree             
D� Camera control panel (PTZ / Two way audio / Instant Playback control panel)
E� Live view window    E� Matrix view window     G� Status panel     H� Event window

H

F
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Quick Access Bar

Some buttons will be disabled if the selected devices do not support those functions�

Live Video Monitoring Window
The "VIVOTEK" logo is displayed where no camera has been assigned to a video cell� 

Icon Function Description

Exit Exit the system

Logout Log out from the current station

Lock Click to Lock the system for security concerns (  Unlock the system)

Volume Adjust the audio volume of the current video (  Mute)

Snapshot Capture pictures from the focus live video cell

Print Print out the pictures of focus live view window or all live video cells

Record to Media Record media in EXE/3GP/AVI format (  Recording Media)

Alert Sound Play sound when an event triggers

Switch Screen Switch the current window to another screen

Remove All Connections Remove all live videos from the live view window

Layout Change the layout of the live view window

Full Screen Maximize the live video cell

Page Up Switch to the previous live view page

Page Down Switch to the next live view page

Start / Stop Rotating Start or stop live view layout rotating

The red frame (  ) represents the current video cell�

Video Cell
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Hierarchical Management Tree

Root Station Name (IP address)

Connected devices listed under the root station
Camera name (IP Address)

Connected devices that have been assigned to 
the default recording storage

Layout list

Icon Description

A station (The host that’s installed with VAST Server)

A station (The host that’s installed with ST7501 Server)

 / / VIVOTEK fixed network camera
Red dot signifies that the camera is recording.

 / / VIVOTEK PTZ network camera
Red dot signifies that the camera is recording.

 / / VIVOTEK dome network camera
Red dot signifies that the camera is recording.

 / VIVOTEK video server
Red dot signifies that the video server is recording.

// Digital input on / off

// Digital output on / off

A layout of the live monitoring window

A station that’s not able to be connected currently�

A device that’s not able to be connected currently�

Sub-station Name (IP address)



 

 

 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
User's Manual - 15  

Camera Control Panel

Pan/Tilt/Zoom (PTZ) Control Panel

  There are two types of PTZ control: Digital (E-PTZ for megapixel cameras) and Mechanical (PTZ cameras or 
fixed cameras with camera control via RS-485)� If the linked network cameras support PTZ/E-PTZ function, 
the option(s) will appear on the drop-down list� For detailed camera control settings, please refer to the user's 
manual of VIVOTEK network camera �

  Click System > Enable Click On Image  to use the mouse for the control of the PTZ and e-PTZ functions in the 
video cells for linked cameras� An icon  will appear in the video cell as shown below�

  You can control the PTZ function through joystick as well� For more information regarding to the joystick 
configuration, please refer to instruction on page 118�

Top left

Left

Bottom left

Focus near
Close

Start to auto pan

Zoom out

Up

Return to home position

Bottom right

Right

Top right

Down

Focus far
Zoom in

Open

Start to auto patrol
Stop auto panning/patrolling

Drop-down list of preset positions

Auto focus

Auto iris
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Two Way Audio Control Panel

The two way audio function allows the user to remotely communicate with people nearby the 
network camera�

  For detailed information about How to Use the Talk Panel, please refer to page 94�
  Only cameras with the two way audio function can be added to the Talk Panel�

Language Selection

VAST currently supports multi-lingual user interfaces including: English, Deutsch, Español, Fran-
çais, Italiano, 日本語, Português, 簡体中文, 繁體中文� If you want to select another language for the 
interface, please click System > Language on the menu bar to select the desired language� 
Please note that if you want to change the language option, a message will pop up to remind 
you to restart the system�

Remove all cameras 
from the Talk Panel

Click to play sound from the camera
Click to talk

Click to adjust volume

Selected device that 
can use the two way 
audio function

Click to play the selected 
sound on the client's side

If you want to use "User Defined" language, please prepare images 
and language strings, and upload the files to the following folders:

...\VAST\Client\LiveClient\language\zz_UD (language string)

...\VAST\Client\LiveClient\image (images)

Select sound from the 
file list
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Event Window

Click View > Event Window to open a window showing the real-time information for event 
triggers� If you want to hide this window, uncheck this option on the menu bar�

  The Type field in the event window shows the event category and another field Description displays 
the percentage of motion in the detection window. You can go to the Configuration setting page of the 
connected device to set the percentage�

For more information about DI/DO settings, please refer to Association Management  on page 49�

Video(TCP-AV)

The default event window is fixed on the bottom 
of the LiveClient� If you want to change the event 
window as a popup page, please click Configuration 
> Client Settings > General Settings to switch the 
modes�

Event Window
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Instant Playback

Check View > Instant Playback to open the window on the panel� 

The event trigger with recorded data will be attached an icon �

You can double-click an event on the list to playback the recorded video� Each event contains 
about 20-seconds recorded video clip�  (The default recording data of an event is 20 seconds� 
For more information about event recording, please refer to page 68�)

Audio Control

The audio function will be enabled if the device is equipped with an internal or external 
microphone� For detailed audio control settings, please refer to page 138�

Instant Playback Window with slider bar, play, pause, and stop function

Uncheck this item if you want to hide this window�
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How to Manage Devices

Please follow the steps below to open the Camera Management window:
a� Select the station from the hierarchical management tree�
b� Click Configuration > Camera Management on the menu bar (or right-click the station, then select 

Camera Management)�
c� Then you can choose to insert, update, delete, or batch insert cameras�

Insert Devices

Please follow the steps below to add devices to a station:
a� Click Configuration > Camera Management > Insert Camera on the menu bar (or right-click the 

device/station, then select Camera Management > Insert Camera)�
b� The Camera Management - Insert window will pop up� The device tree managed by the station will 

be displayed in the left Camera List window�
c� Enter the Camera Name, IP address (or you can enter an IP address and check Auto to get a 

camera name automatically) and configure the Connection Settings�
  If the camera is on the LAN, you can click  Search Camera to detect all VIVOTEK network 

cameras on the LAN� A Camera List window will pop up and show a list of detected cameras on 
the LAN� On the top of Camera List window, you can select "List the cameras which are not 
inserted" or "List all cameras"� The items listed below will then change accordingly� You can click 
Mac, IP Address, Model, HTTP port to sort the items� Then select a camera from the list to insert 
to the station�

  The streaming protocol determines how the live video stream is sent from the camera to the local 
computer� Please refer to the note on the next page for a detailed description of each transmission 
protocol� Specify the recommended live monitoring stream for the device� If you want to change the 
live viewing stream, please refer to the next page to update the camera settings� Or you can right-
click the desired cell, then select a desired stream� Please refer to Dual / Multiple Streams on page 
29 for a detailed illustration�

  Click Detect Model to detect the device� The Model Name and MAC Address of the device will 
automatically be displayed in the respective fields if the connection is successful. 

d� If you want to make sure you are connected to the target device, click Connection Test to preview the 
live video from the device�

b

a

ba
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  If you want to use "HTTPS Port", please enable the HTTPs settings on the configuration page of the Network 
Camera first.

  The characteristics of each protocol are shown in the following table:

Protocol Description

UDP

UDP uses a simple transmission model without implicit hand-shaking dialogues for guaranteeing 
reliability, ordering, or data integrity� Thus, UDP provides an unreliable service and data grams may 
arrive out of order, appear duplicated, or go missing without notice� This protocol allows for almost 
real-time audio and video streams� However, network packets may be lost due to network burst 
traffic and images may be obscured. Activate UDP connection when occasions require time-sensitive 
responses and video quality is less important�

TCP

TCP provides the service of exchanging data reliably directly between two network hosts, whereas IP 
handles addressing and routing message across one or more networks� In particular, TCP provides 
reliable, ordered delivery of a stream of bytes from a program on one computer to another program 
on another computer� This protocol guarantees the delivery of streaming data and thus provides 
better video quality� The downside with this protocol is that the real-time effect is worse than that with 
UDP for a narrower bandwidth�

HTTP
HTTP is a networking protocol for distributed, collaborative, hypermedia information systems� It’s the 
foundation of data communication for the World Wide Web� This protocol allows for the same quality 
as TCP and the users need not open a specific port for streaming under some network environment.  
Users inside a firewall can utilize this protocol to allow streaming data through.

HTTPS This protocol enables authentication and encrypted communication over SSL (Secure Socket Layer), 
which protects streaming data transmission over the Internet on higer security level�

d

c

c

c
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e. Configure Recording Settings: 
  Recording Stream: By default, the stream source of the recording stream is stream 1, if you want to 

change it later on, please refer to the last page to update the camera settings�
     Pre-event time: Enter a number to decide how much time to record before an event is triggered� 
     Post-event time: Enter a number to decide the duration of recording after an event is triggered�

For example: If both the Pre-event time and Postevent time are set to 10 seconds, a total of 20 
seconds video will be recorded if an event triggers� This function is supported by the buffer area of 
VAST server (time shift cache stream)�

  Minimum pre-event time: Due to the limited cache memory of each network camera, the pre-event 
time of time shift cache stream on camera may be very short� Then you can choose to set pre-event 
recording on the VAST server� For example: To set up minimum 5 seconds� If the cache memory 
of the selected Network Camera can only support up to 3 seconds, the VAST Server will switch to 
enable pre-event recording for 5 seconds by itself, rather than request the time shift cache stream 
from the network camera server� 

Please note that if you want to enable activity adaptive stream, we suggest you right-click  the camera on the 
heirarchical management tree > Camera Settings > Audio and Video  to activate "Time Shift Cache Stream"  on 
the camera and select a stream source� This will help record complete pre-event recording�

  Activity Adaptive Stream (active if possible): Check 
this item to enable activity adaptive stream recording 
and time shift recording� For cameras combined 
with time-shift cache stream and multiple streams 
features, user can make use of activity adaptive 
streaming for dynamic frame control�
If you check Activate Activity Adaptive Stream and 
enable time-shift cache stream on the camera, 
only when an event is triggered on the camera will 
ST7501 Server record the full frame rate streaming 
data; otherwise, it will only request the I frame data 
during normal monitoring, thus effectively save lots 
of bandwidths and storage� Time

Bandwidth

Bandwidth

Activity Adaptive Streaming 
for Dynamic Frame Rate Control

I frame   --->   Full frame rate   --->   I frame

Continuous recording

post-
10 sec.

pre-
10 sec.

Trigger Activation

Pre-event time Post-event timee
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f� The device will automatically be assigned to the default recording group� Uncheck the item if you want 
to cancel this setting�

g� When all settings are completed, click Insert to add the device to the station� The device will be 
displayed under the left Camera List�

h� To insert additional devices to the station, repeat the above steps� 
i� When completed, click Close to exit the camera management window�
j. Back to the main window, you will find the newly-inserted devices displayed under the station and the 

live video in the video cell�

f
g i

g
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Update Devices

Please follow the steps below to update a device via Camera Management window:
a� Click Configuration > Camera Management > Update Camera on the menu bar (or right-click the 

device/station, then select Camera Management > Update Camera)�
b� The Camera Management - Update window will pop up� The device tree managed by the station will 

be displayed in the left Camera List window�
c� Select a device from the list you want to update� Its related information will automatically be displayed 

in the corresponding fields in the Camera Management window� Then you can modify Connection 
Settings and Recording Settings of the device�

d� After modifying the settings, you can click Connection Test to preview the live video from the device�
e� When all settings are completed, click Update to enable the settings� 

b

c

e

d

a
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Delete Devices from the VAST Server

  Delete a device:
Right-click the device on the device tree, then select Delete. A dialog box will pop up� Click Yes to 
delete the device along with the recorded data; click No to delete the device but retain the recorded 
data; click Cancel to cancel the delete action�

  Delete more than one device at a time:
a� Click Configuration > Camera Management > Delete Cameras on the menu bar (or right-click the 

device/station, then select Camera Management > Delete Cameras)� 
b� The Delete Cameras window will pop up� 
c� Select the devices you want to delete from the list, then click Delete�
d� A dialog box will pop up� Click Yes to delete the device along with the recorded data; click No to delete 

the device but retain the recorded data; click Cancel to cancel the delete action�
e� When completed, click Close to exit the Delete Cameras window and return to the main window� The 

deleted device will disappear from the station�

b

a

c

d

e
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Batch Insert Devices

Batch insert is a very useful function that allows user to search, filter, and import a row of 
devices to the station on the LAN at a time� The basic settings can also be applied to those 
inserted devices simultaneously�

Please follow the steps below to batch insert devices to a station:
a� Click Configuration > Camera Management > Batch Insert Cameras on the menu bar (or right-

click the station, then select Camera Management > Batch Insert Camera)�
b� The Batch Insert Cameras window will pop up� Then click Search to open the Search Camera 

window�
c� On top of the Camera List window, you can select "List the cameras which are not inserted" or "List all 

cameras"� The items listed below will then change accordingly�
d� Use the 4 Filters to narrow down the range of the wanted cameras from the list�
  IP Range: Type in a range of IP address to narrow down the list; the filter automatically filters after 

you fill in a correct IP range.

b

c

d
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  IP with prefix: Type in the prefix of the IP address to narrow down the list.

  Model with prefix: The user can type in the prefix of the model name or the complete model name of 
the cameras to narrow down the list�

  MAC with prefix: You can type in the prefix of the MAC address of the cameras to narrow down the 
list�
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e. When the list is filtered, you can select the cameras one by one or check Select All to add them to the 
batch insert list� Then click OK to finish searching.

f� The selected cameras will be shown on the batch insert camera list with the camera information and 
the connection status� When you click on a camera, a live view will show up on the right side for you to 
identify the cameras on the list� If you want to remove a camera from the list, click the trash can icon to 
delete it�

g

f
h

j

i
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g. On the bottom of the window, there is a field for you to alter the camera settings including Connection 
Settings and Recording Settings� You can apply the new settings to each camera on the list, or 
click Apply to All to apply the same configurations to all the cameras. For more information about 
Connection Settings and Recording Settings, please refer to Insert Device on page 19 for detailed 
information�

When you modify the camera settings, once the connection information (User Name, Password, Configuration 
Protocol, Configuration Port, and Streaming Protocol) is not matched to the network environment, the camera will 
be disconnected and the status of the camera will become “Camera cannot be found” as shown below�

h� Specify host: If you want to add a camera to the list, click Specify 
Host to directly add a wanted camera� Click Add after filling in 
the correct information� The camera will be added to the list of the 
Batch Insert Camera window�

i� By default, all inserted devices will be applied to the default 
recording group� Uncheck Add to if you do not want to assign the 
selected devices to the default recording group�

j� Click Insert when all the settings are done� The settings will be 
applied�
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View Live Videos

The server will automatically add a newly-inserted device to the video cell for live viewing� 
You also can double-click the target device or drag-and-drop the target device from the 
hierarchical management tree window to the video cell�

Dual / Multiple Streams

For dual-stream devices, you can right-click on the focused cell to select stream 1 or stream 2� For 
multiple-stream devices, you can select from stream 1 ~ stream 4�

Refresh

Right-click the device, then click Refresh, the camera information will be refreshed from the server�

Streaming Server

Right-click the station or the device and click Output Streaming URL. A .txt file with streaming URL will 
pop up� Then you can use this URL to link to the live streaming through QuickTime Player�
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Camera Settings

Right-click the device, then click Camera Settings to open the LiveClient Browser to configure detailed 
information� 

Remove Live Video from the Video Monitoring Window

There are two ways to remove a live video from the video cell: 
Method 1� Right-click the video cell and select Remove�

Method 2� Drag-and-drop the live view from the video cell to the hierarchical management tree window�

If you want to remove all live videos from the video cells, please click  on the menu bar�

Some functions in the browsing window in 
the VAST software will be disabled due to 
limitations� If you need to change the settings, 
use your own browser to connect to the 
device directly�
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How to Change the VAST LiveClient Layout

Changing the Layout of the Live Video Monitoring Window

VIVOTEK VAST LiveClient supports up to 32-CH simultaneous video viewing on a single 
monitor and allows you to change the layout of the live video monitoring window based on the 
number of inserted devices� 

Switch Video Channels

To move a video channel to another empty video cell, drag-and-drop the view to the target video cell�

To switch two different channels, drag-and-drop one view to the other, then the two different channels 
will be switched to the opposite�

Configure Layout Mode

Click the Layout button  on the quick access bar� Select a desired layout mode, and the layout 
window will be changed accordingly� Below we illustrate 8 types of layout modes and the corresponding 
page numbers:

Some layout modes (1 x 1, 2 x 2, 1 + 5, 3 x 3, 1 + 12, 4 x 4) will divide all video channels into several 
pages� 

Layout mode Description Video page

1 x 1 32

2 x 2 8

1 + 5 4

3 x 3 3

1 + 12 2

4 x 4 2

5 x 5 1

1 + 31 1

drag-and-drop the view to the target video cell

More than 1 video page; 
rotation function is enabled

Only 1 video page; 
rotation function is disabled
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For example, under 3 x 3 layout mode, you can switch among the pages by clicking   and   on 
the quick access bar� To arrange the content of each page, manually drag-and-drop cameras from the 
hierarchical management tree to the video cells on each page�

Rotating Video Pages

For layout modes that contain more than one page, ST7501 LiveClient offers the rotating function for 
displaying all video pages in turn� 
  To enable this function, click  on the Quick Access Bar, which will become  Stop Rotating, and 

the video pages will start to rotate so that the user does not have to click  to move to the next page� 
  To disable this function, click  Stop Rotating, which will become  on the Quick Access Bar�

You can also click Layout > Start to Rotate/Stop Rotating to enable/disable this function�

The default rotating time interval is 6 seconds� If you want to edit rotation settings, please refer to 
Rotation Settings on page 116�

Edit Layout

Please follow the steps below to save a layout:
a� Arrange a layout mode and drag devices to their desired video cells�
b� Click Layout > Edit > Save to > New on the menu bar� A Layout Name dialog box will pop up�

c� Enter a name for the the layout, then click OK to enable the setting�

1 2 3

16
4 5 6
7 8 9

10 11 12
13 14 15

Page 1 Page 2 Page 3

17 18

19
22

2120
23 24

25 26 27



 

 

 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
User's Manual - 33  

d� Back to the monitoring window, the new layout will be displayed under the hierarchical management 
tree as shown below� You can save up to 10 layouts�

e� To change to another layout, double-click the layout options on the hierarchical management tree, or 
click Layout > Choose on the menu bar to select a desired layout�

  If you want to edit an existing layout, arrange a layout mode and drag devices to the desired video 
cells, then click Layout > Edit > Save to > New to save as a new layout or an existing layout to 
replace with the new one�

  If you want to delete an existing layout, right-click the layout item on the hierarchical management 
tree or click Layout > Edit > Delete on the menu bar to delete it�
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Maximize/Minimize the Live Video Monitoring Window

  Single View: to maxmize a video cell to the entire live video window

Double-click the video cell, or right-click the video cell and select Single View� The focused video will 
occupy the entire playback window as shown below�

To restore to the original layout, double-click the video cell or right-click the video cell and uncheck 
Single View.
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  Full Screen: Maximize the live video monitoring window to the entire screen

Click Full Screen  on the quick access bar or right-click the video cell and select Full Screen� In 
addition, you can also click View > Full Screen on the menu bar to maximize the live video monitoring 
window�

To restore to the original layout, you can right-click a video cell and uncheck Full Screen or click the 
Esc button on the keyboard to exit full screen mode�

  Minimize: If you click View > Minimize on the menu bar, LiveClient will minimize to the Windows tool 
bar�

View Live Video on Dual Monitors

VAST also supports live video viewing on dual monitors, allowing you to manage maximum 64 
channels on two screens concurrently� Moreover, the layout of the video monitoring window on 
different monitors can be set up individually� 

Please follow the steps below to set up dual-screen mode:
a� Set up dual monitors for your local computer�
b� Launch VAST LiveClient on monitor 1�
c� Click System > Second View on monitor 1, then the live video monitoring window will be displayed in 

monitor 2 as shown below�

d� There are two ways to view live videos� One is to drag-and-drop the target device from the 
hierarchical management tree window to the video cells� The other is to click any video cell on monitor 
1 or monitor 2, then double-click the target device; the live video will be displayed in monitor 1 or 2 in 
accordance with your selection�

e� If you click Switch Screen  on the quick access bar, the live monitoring window on monitor 1 and 
monitor 2 will swap�

Monitor 1 Monitor 2

c

e
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View up to 64 channels simultaneously

If you select 1+31 layout on dual screens, you can view a maximum of 64 channels live video 
simultaneously� In this case, each layout contains 32 channels on 1 video page�

Using different layouts on each monitor

You also can select different layout for two monitors, simply click the Layout button  on the quick 
access bar� Below is an example of the 2x2 layout with 8 video pages on monitor 1 and the 4x4 layout 
with 2 video pages on monitor 2� You can click  and  to switch among the video pages�

Monitor 2 - page 1Monitor 1 - page 1

Monitor 1 - page 2
Click

1 2

3 4

5 6

7 8

34 35 36
37 38 39 40

41 42 43 44

45 46 47 48

33

Monitor 1 - page 8

50 51 52
53 54 55 56

57 58 59 60

61 62 63 64

49

Monitor 1 - 32 channel Monitor 2 - 32 channel

Monitor 2 - page 2
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View Live Video with Multiple Monitors

If you have multiple screens in your monitoring center, you can switch the VAST LiveClient 
Window among these screens�

 If you have two monitors, click Switch Screen  on the menu bar; the LiveClient window on monitor 1 
will switch to monitor 2�

 If you have three or more monitors, a drop-down list will be displayed when you click Switch Screen 
 on the menu bar� The number of items on this list depends on the number of your screens� Select a 

desired screen on the drop-down list and the LiveClient Window will switch to the specified screen.

Monitor 1 Monitor 2

Monitor 1
Monitor 2
Monitor 3
  ......
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How to Manage Station
The VAST Server allows you to construct a hierarchical management system by adding more 
sub-stations to the root station� Under each sub-station, it can also insert sub-stations and 
network cameras�

Relay Settings

Before adding a sub-station, please follow the instruction below to enable the sub-station's 
Relay Settings first.
a� Login to the sub-station�
b� Select the station from the hierarchical management tree�
c� Click Configuration > Station Settings > Relay Settings on the menu bar (or right-click the station 

on the hierarchical management tree and select Station Settings > Relay Settings)� 

d� The Relay Settings window will pop up� Check Allow Relay Connection and enter a Password� 
Then click OK to enable the settings�

b

c

d
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Insert Sub-stations

Please follow the steps below to add sub-stations:
a� Select a target station from the hierarchical management tree�
b� Click Configuration > Station Management on the menu bar (or right-click the target station, then 

select Station Management)�
c� The Station Management window will pop up� The hierarchical management tree managed by the 

target station will be displayed in the left window�

d� Before inserting the sub-station, you can click List Sub-station Hierarchy button to know if there is 
any sub-station under it� 

e� Enter the sub-station's IP address and Password (defined in Relay Settings, not login password)� 
The default communication port is 3454�
  If the sub-station is on the LAN, you can click the Search Station button to detect all ST7501 and 

VAST on the LAN� A Station List window will pop up and show a list of detected cameras on 
the LAN� On the top of Camera List window, you can select "List the stations which are not 
inserted" or "List all stations"� The items listed below will then change accordingly� You can click 
Name, IP Address, Model, Http port to sort the items� Then select a device from the list to insert 
to the station�

b
a

b

c
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f� When all settings are done, click Insert to add the sub-station to the target station� The sub-station will 
be displayed under the left station tree�

g� To insert additional sub-stations to the target station, repeat the above steps�
h� When completed, click Close to exit the Station Management window�

i� Back to the main window, you will find the newly-inserted stations displayed under the hierarchical 
management tree�

e

d
f

f

h

e

e
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  You can add VAST or free standard ST7501 as the sub-stations� The number of sub-stations can be added to the 
server depends on your key dongle� The VAST server will automatically detect the USB dongle installed on your 
host PC� Following is an illustration for two-level hierarchical architecture:

  Please note that the following cyclic relay is not allowed�

Server A Server C

Server B

Add server B 
as substation 

Add server C 
as substation 
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Delete Sub-stations

There are two ways to delete a sub-station:
Method 1� Select the sub-station on the hierarchical management tree, then right-click to delete�

Method 2� Delete the sub-station via the Station Management window:
a� Click the station on the hierarchical management tree, then click Configuration > Station Manage-

ment on the menu bar (or right-click the station, then select Station Management)� 
b� The Station Management window will pop up� The hierarchical management tree managed by the 

station will be displayed in the left Station List window�
c� Select a station from the list you want to delete� Its related information will automatically be displayed 

in the corresponding blanks in the Station Management window� 
d� Click Delete to delete it� 
e� To delete additional devices, repeat step c� and d�
f� When completed, click Close to exit the camera management window and return to the main window� 

The deleted device will disappear from the hierarchical management tree� 

d

c

f
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Update Stations

Please follow the steps below to update a station via Station Management window:
a� Right-click the target device on the hierarchical management tree and click Station Management.
b� The Station Management window will pop up� The hierarchical management tree managed by the 

station will be displayed in the Station List window on the left�
c� Select a station from the list you want to delete� Its related information will automatically be displayed 

in the corresponding blanks in the Station Management window� 
d� When all settings are completed, click Update to enable the settings� 

a

d

c

b
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How to Manage User Accounts

VAST allows users to apply multiple user accounts to a station with five levels of user roles: 
Administrator > Power User > User > Operator > Guest� Each role has different permissions 
listed as shown below� Moreover, Administrators have the highest privileges, while Power Users 
can only add/edit users as Power Users, Users, Operators, and Guests�

The Default User Roles and Permissions of User Accounts
Functions \ User Roles Administrator Power User User Operator Guest Description

Station Management Add sub-station under the 
existing station

User Management Manage user accounts

Camera Management Insert and configure the 
camera settings

Association 
Management

Access and modify the 
association settings

Access Event 
Management Access event management

Modify Event 
Management Modify event management

General Station 
Settings

Modify general station 
settings

Station Network 
Settings Modify network settings

Access Recording 
Storage/
Recording Schedule 
Settings

Access the recording group 
and recording schedule

Modify Recording 
Storage/
Recording Schedule 
Settings

Configure the recording 
group and recording 
schedule

Manually Record Enable the recording 
function manually

Scheduled Backup 
Settings Configure backup schedule 

Access Server Settings Access server settings
Modify Server Settings Modify server settings

License Management Allow user to manage 
station licenses

Relay Management Allow user to manage 
station relaying settings

Client Settings
Configure the client 
settings: snapshot, AVI, 
etc�

Video Enhancement 
Settings

Allow user to edit profile for 
video enhancement and 
assign profile to camera in 
LiveClient
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Manage a User Account

Add a New User Account
a� Select the station from the hierarchical management tree�
b� Click Configuration > User Management on the menu bar (or right-click the station, then select 

User Management)� 

Privileges \ User Roles Administrator Power User User Operator Guest Description

Modify Directories Add, remove and rename 
directories

Delete Station Delete sub-station from a 
(parent) station

Delete Camera Delete camera from the 
station

PTZ Control
PTZ control for PTZ 
cameras and speed domes 
in LiveClient

Device Control
Control the digital output or 
white light/IR illuminators of 
the cameras

Talk Control Two way audio function for 
the cameras

Access Camera 
Configuration Access the camera settings

Modify E-map Allow user to modify the 
E-map

Event Search Use built-in search engine 
to search specific events

Log Viewer Use built-in search engine 
to search the log

Backup Back up database manually

Record/Export Media
Record live stream or 
export playback stream to 
local files

Virtual Matrix 
Management

Allow user to manage 
virtual matrix

Virtual Matrix Control Allow user to control virtual 
matrix

b
a

b
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c� The User Management window will pop up� The user accounts under the station will be displayed 
under the left User List tree� 

d� Enter the User Name, Password, and specify the User Role of this user�
e� Click Add to add the user account to the station� It will be displayed under the User List� 

c
d

e

e
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Permission of the User Account
Administrator is granted with all access privileges, while other user roles' permission is limited� If 
you want to modify the permission, please login as the Administrator to configure the settings.
f� Select a User account from the User List tree�
g� If you want to set the limit of the permission of the user, click Permission tab to check or uncheck the 

items� 

h� If you want to limit the devices accessible by the user, click Accessible Cameras tab to select the 
desired devices�

h

f

g
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i� If you want to set the access limit of the sub-station accessible by the user, click Accessible 
Substations tab to select the desired devices�

If you want to remove access permission mentioned above from the account, the user will not able to operate some 
functions listed in the following warning dialog�

j� When completed, click Update to enable the new settings�

Delete the User Account
k� Click Delete, a delete user dialog will pop up� Click OK to delete the user account�

If the Administrator modifies or deletes the User Account, that modified user might be kicked off from the station.

i

jk
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How to Set up Association Management
VAST LiveClient supports association management which allows the user to configure relative 
event trigger notifications of connected network devices. (Eg. DI/DO status on the hierarchical 
management tree, motion detection windows appear in the video cell, the event list in the event 
window)

Association Management

Please follow the steps below to configure assocation settings:
a� Select the station from the hierarchical management tree�
b� Click Configuration > Association Management on the menu bar (or right-click the station and 

select Association Management)� 

c� The Association Management window will pop up� Check or uncheck the items and click Save 
to enable the settings� The items you've selected will also be displayed under the hierarchical 
management tree� 

    For example:

d� If you want to rename the DI device, select the DI item and click the Rename button� It will be very 
convenient for you to recognize the target DI device�

// Digital input on / off

// Digital output on / off

a

b

b

d
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 To manually enable DI/DO settings, please right-click  the video cell and select Set DO  to enable (Trigger) or 
disable (Normal) the digital output of the linked device�

  Before you configure the DI/DO Settings for VAST, please enable DI/DO settings on your network device and set 
up the camera correctly on the configuration page. You can right-click  the device and click Camera Settings  to 
open the configuration page.
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How to Set up Event Management
VAST LiveClient supports event management which allows the server to respond to particular 
situations (events)�

Event Management

Please follow the steps below to configure event management:
a� Select the station from the hierarchical management tree�
b� Click Configuration > Event Management on the menu bar (or right-click the station and select 

Event Management)� 

c� The Event Management window will pop up� Click New to set up a new event. When you finish the 
general settings, click Next to set up trigger source settings�

d� Click Add to select the trigger source by Device or Trigger Type� 

a

b
b

Detect next event after 5 secs
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e� The Device List window will pop up� Select one or more devices and set the Notification Type� 
Depending on the trigger source, the Notification Type will be different� Then click OK to close the 
window� 

f� The trigger source(s) will be listed on the window as shown below� If you want to add more Trigger 
sources, click Add and repeat d�~e� Then click Next to assign action(s) to the trigger source(s)�

g� Click Add to open the Action Settings window� 

There are several types of Action Settings�
  Email: The sever will send a notification via e-mail when a trigger is activated.

h� To enable this function, please set up the SMTP server first� Click SMTP Setting to open the 
window and refer to page 93 for detailed information�

i� Enter the related informtaion� You can modify the mail content in the blank� If you want to modify the 
content, click Insert Macro to select the parameter� When completed, click OK on the bottom to 
enable the setting�

f

g

h
i
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 Start to record on: The sever will start to record video from selected camera(s) when an event is 
triggered� 
j� Click Add Camera to select the target camera(s)�
k� The selected camera(s) will be listed on the left window below� When completed, click OK on the 

bottom to enable the setting�

  Move to preset location: The target camera(s) will move the shooting area to the preset location(s) 
when an event is triggered� 
l. To enable this function, please set preset locations on the camera configuration page first. 
m� Click Add Location to select preset location(s)� 
n� The selected preset location(s) will be listed on the left window below� When completed, click OK on 

the bottom to enable the setting�
   

  Set DO: Select this option to turn on external digital output device(s) when an event is triggered� For 
more information about how to set DI/DO settings on the target camera, please refer to page 49� 
o� Click Add DO to select DO decive(s) and select a DO status (Normal or Trigger)� 
p� The selected DO device(s) will be listed on the left window below� When completed, click OK to 

enable the setting�

j

j
k

m
n

n

o

o
p

k

p
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  GSM Short Message: The sever will send a short message to a GSM cell phone when an event is 
triggered� 
q� Please enter the Phone Number and open GSM Settings window to set related information if 

necessary� When completed, click OK to enable the setting�

  HTTP: This function allows user to send a CGI command to the linked network camera, such as pan/
tilt/zoom function or enable DO devices� 
r� You can click Insert Macro to select the parameter� Please enter authentification information 

i f necessary. For example: http://192.168.3.66/cgi-bin/admin/setparam.cgi?system_
hostname=$(EventTime) $(CameraName)
If you want to use special characters such as $-_.+!*'(),#%+$,@:;/?=&, please refer to the 
following table to transfer the Code (Hex)� 
For example: http://192.168.3.66/cgi-bin/admin/setparam.cgi?system_hostname=123&456
                 --> http://192.168.3.66/cgi-bin/admin/setparam.cgi?system_hostname=123%26456

Please enter the country code if you use overseas call�

Character Code (Hex)
! 21
# 23
$ 24
% 25
& 26
' 27
( 28
) 29
* 2A
+ 2B

Character Code (Hex)
, 2C
- 2D
. 2E
/ 2F
: 3A
; 3B
= 3D
? 3F
@ 40
_ 5F
~ 7E
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s� The action(s) will be listed in the window as shown below� 
    Then click Next to set up schedule(s) to the action(s)�
    For more information about Schedule Settings, please refer to Recording Schedule Settings on page 

70� You can assign more than one time frame to one action�
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t� When you finish schedule settings, click Next to review the detailed information of the new event 
settings�  

u� Following is the detailed information of the new event setting� You can click Back to modify the event 
setting or click Finish to close the window�

v� Following is an example of an enabled event� You can click New to set up more events or click Close 
to exit the window�

If your target station has sub-station(s), the trigger sources  can be selected from the device(s) under the sub-
station(s); while the actions  can only be performed on the device(s) under the target station� 

Click to disable or modify the selected event

Click to remove the event
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How to Manage the Virtual Matrix

Virtual Matrix is a very useful tool for multiple monitor display and management� Based on the 
whole surveillance system architecture, it efficiently helps user construct a real-time live video 
wall in the control center� Under a large-scale hierarchical system, through VAST LiveClient 
you can only simultaneously monitor up to 64-CH on dual monitors; while Virtual Matrix offers 
fully extension for numerous channels and screens, thus making VAST a very powerful central 
management system� Moreover, you can change the layout to 2x2 or 3x3 on each monitor 
to enlarge the video size, then display the video pages on saperate monitor for close-up 
monitoring� 

The architecture of VAST Matrix
As the following picture shows, the surveillance system architecture is composed of VAST LiveClient, 
VAST Server with two sub-stations, and VAST Matrix separately on individual hosts� Before constructing 
the Virtual Matrix, please install and run VAST Matrix Program on Matrix Recipient connected with the 
video wall� Through the Virtual Matrix connection, you can use LiveClient to log in the root server to 
remotely manage and display all the live view onto the video wall by easily drag-and-drop�

VAST-64-CH on dual monitors

Video Wall of Virtual Matrix

VAST Server
(Root Station)

VAST
LiveClient

VIVOTEK IP CameraVIVOTEK IP Camera

VIVOTEK IP CameraVIVOTEK IP CameraVIVOTEK IP CameraVIVOTEK IP Camera

VAST/ST7501 Server
(Sub-station)

VAST Matrix 
Recipient 1

VAST Matrix 
Recipient 2

Video Wall
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Installing VAST Matrix Program

Please follow the steps below to install VAST Matrix Program:
a� Run VASTMatrix_setup.exe on another host (Matrix Recipient)� Then click Next to start installation 

wizard�

b� Carefully read to accept the End-User License Agreement for use� Click I Agree to the next step�
c� Choose the installing path as the destination folder, the required space and available space of the hard 

disk will be shown below for reference� Click Next to the next step�

d� Fill in the connection information with Port, Account & Password for VAST Server to connect to the 
Matrix Recipient�
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e� Click Finish to close the installation wizard, and you might want to run VAST Matrix immediately after 
installation by selecting the option Run VAST Matrix�

Launching VAST Matrix

Please follow the steps below to install VAST Matrix Program:
a� Click the desktop icon to start VAST Matrix� When it’s begun running, there will be a VAST Matrix tray 

icon on the toolbar for the user to configure easily.

b� The VAST Matrix live view window with multiple types of layout will be displayed� The following shows 
32-channels layout�

c� Right-click on the live view window, a function menu will pop up� You may also open the menu by 
right-click on the tray icon�
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Configuration
  Connection: Enter the account, password and port information for the VAST Recipient�
  Monitor: It shows the monitor(s) connected to your host� You can select the monitor(s) you wish to 

display as the video wall�
  Others

Auto launch at windows startup: Select this option if you want VAST Matrix to launch when windows 
starts up in case to avoid the computer reboots by itself and accidentally shuts down VAST Matrix� 
Display key frame only: Select this option to display live video with the key frame only in order to save 
the bandwidth� It also lowers down the CPU loading and memory usage� 
Enable de-interlace: Select this option if your linked device does not support de-interlace function� For 
example: VS7100�

View Settings
Please refer to page 114 for detailed illustration�

About
This dialog that shows the version of VAST Matrix and the simple statement of the version copyright�

Exit
Click to close the VAST Matrix� 
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VAST Matrix Management

Once the VAST Matrix Program is setup completely, the next step is to connect the VAST Server with 
VAST Matrix Recipient(s)� Use LiveClient to log in VAST Server, then click Configuration > Virtual 
Matrix Management to configure Matrix Management and Matrix View Settings.

Matrix Management Settings
Please follow the steps to set up VAST Matrix Recipient(s):
a� Click Configuration > Virtual Matrix Management > Matrix Management to open the Matrix 

Management window�
b� Manually enter the Matrix Recipient Info as previous settings, or you click the search button  to 

search for the Matrix Recipient(s) on the LAN�
c. When the information of the target recipient is filled in, you can use the detect button  to confirm if 

the filled information is correct. 
d� Click Add, then the recipient will be displayed on the Matrix Recipients list window� 

e� Click Edit display settings to set up the viewing interface for the monitors (video wall) connected to 
the Matrix Recipient host�

b

c

d

d

e

The Matrix View display is capable of executing rotation� The 
default interval time is set at 10 seconds�
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f� If you want to set up more Martrix Recipients, repeat the above steps�
g� If you want to modify the Recipient Info, select it from the list to change settings, then click Update to 

enable the new settings�
h� When all settings are done, click Close to exit the Matrix Management page�

Manage VAST Matrix through VAST LiveClient
Once the setup is complete in Virtual Matrix Management, you may go back to the main page of 
LiveClient, the connection between VAST Server and VAST Matrix will be working successfully� Then 
you can choose Matrix Recipient and the monitor from the drop-down list for the operation control� Some 
buttons on the quick access bar will be disabled when you switch from the Live View Panel to Matrix 
View Panel�
  Change the layout
As the following picture shows, you can click  to change the layout and set new layout group on the 
Matrix View Panel as easy as control of the LiveClient� The layout on the monitor (video wall) will also 
change synchronizely once you change the layout on Matrix View Panel�  

  Connection status
If the VAST Server is not able to connect to the Matrix Recipient, the status icon will become     
and show the reason of disconnecting when you slide the mouse to the connection status icon� The 
"Connection Lost" string will be displayed on the Matrix View window as shown below� 
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  Rotation
VAST Matrix is capable of executing rotation by clicking � You can even select another layout group 
on the Matrix View window without stopping the rotation� If you want to adjust the rotation interval time, 
please refer to Edit display settings on page 61 for adjusting�

  PTZ 
VAST Matrix is capable of supporting PTZ control panel as on the LiveClient� 

  Matrix View Menu 
Right-click on the window to open the menu� 
Remove: Remove the channel from VAST Matrix� 
Stream 1 ~ 4: Switch the camera stream between 1 ~ 4�

  Remove All Connections
It’s capable of removing all connections from VAST Matrix once by clicking on  button�

Matrix View Settings

Click Configuration > Virtual Matrix Management > Matrix View Settings to open the window�

  Media Source
You can choose the path of media source from camera directly or the CMS server to display on Matrix 
View� 

  Display Settings
You can choose the display frame rate as full frame rate or key frame only�
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How to Configure the Station General Settings

Select the target station from the hierarchical management tree, then click Configuration 
> Station Settings > General Settings on the menu bar (or right-click the station on the 
hierarchical management tree and select Station Settings > General Settings)� The Station 
General Settings window will pop up�

Server Settings
In this section, you can modify the Station Name�

Log Settings
In this section, you can set up Log Settings for the station� 
The VAST server allows user to search for the recorded 
log through VAST Playback� For more information, 
please refer to How to Search Logs on page 165�
  Log level: Select High (only record high-level logs), 

Normal (record high-level and normal-level logs), Low 
(record all logs)� For detailed information about log 
levels, please refer to page 166�

  Reserve Time: Enter the time interval that you want 
to reserve the log record� The maximum value is 365 
days�
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How to Configure Station Network Settings

Select the target station from the hierarchical management tree, then click Configuration 
> Station Settings > Network Settings on the menu bar (or right-click the station on the 
hierarchical management tree and select Station Settings > Network Settings)� The Network 
Settings window will pop up�

Port Settings
  Server port: The default server port is set to 3454� If you  

change the server port, please enter the new value while 
logging the LiveClient next time�

  RTSP port: The RTSP (Real-Time Streaming Protocol) 
controls the delivery of streaming media� By default, the port 
number is set to 554�

UPnP Settings
  Enable UPnP port forwarding: For client to access the 

VAST Server from the Internet, select this option to allow 
the server to open ports on the router automatically so the 
video streams can be sent out from a LAN� To utilize of this 
feature, make sure that your router supports UPnPTM and it 
is activated�

  Enable UPnP presentation: If you select this option, 
shortcuts to VAST Server will be listed in My Network 
Places� 

Proxy Settings
In this section, you can enable, modify, or cancel Proxy Settings for VAST Server if your network 
devices are set up under a proxy�

Web Access Settings
User can access VAST LiveClient and Playback via Internet web browser (http://IP address:3454)�
For local host --> http://127�0�0�1:3454�
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How to Edit Recording Groups

By default, all devices are assigned to the default recording group� You can manually remove 
a device from the default recording group� However, only those devices which belong to a 
recording group can produce recorded media files.

Another purpose of setting recording group is that you can divide all the managed devices into 
several recording groups, and for each recording group, you can assign several hard-disks (with 
recording paths) to store media data� The live media data will be stored in the first assigned 
hard-disk initially, and when the available space of the first hard disk reaches the preset 
reserved space limit, the media data will be stored in the second disk and so on� If the available 
space of the last disk reaches the reserved space limit, the recorded files in the first disk will be 
overwritten with the new media data� This procedure is called "Cyclic Recording"�

Recording Storage Settings

Please follow the steps below to set up recording groups for a station:
a� Select the target station from the hierarchical management tree�
b� Click Configuration > Station Settings > Recording Storage Settings on the menu bar (or right-

click the station on the hierarchical management tree and select Station Settings > Recording 
Storage Settings)� You can also right-click DefaultGroup under the station and click Recording 
Storage Settings since all devices are assigned to the Default Recording Group by default settings�

c� The Recording Storage Settings window will pop up� 

b

a

b

b
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Defult Storage Group Settings
The following example shows the default storage group settings� You can click  Rename to modify the 
group name or click  Delete to remove the default settings�

d� The default recording path is C:\Recording� The total space and free space of the disk is shown on 
the right for reference� 

e� Add Local Path: Click  to add another recording path on your local computer� A Select Path dialog 
will pop up as shown below� When all settings are complete, click OK to enable the settings, or click 
Cancel to discard the settings�

f� Add Network Path: Click  to add a network storage for recorded data� Please refer to page 92 for 
detailed information about how to add a new network storage server� Then double-click the Path to 
assign a specific folder as a new recording path.

d

e

Click those buttons to modify the file 
folder under D:\

f
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g� To modify the settings of a path, select the path from the list, then click  Change settings to modify�
h� To delete a path, select the path from the list and click  Delete path� A warning dialog box will pop 

up  as shown below�

i� By default, all devices are assigned to the Default Recording Group in the window on the right� You 
can select device(s) from the list and click << to delete device(s) (or right-click the device under 
DefaultGroup tree to delete it)� Note that a Delete Camera dialog box will pop up� Click Yes to delete 
the device along with the recorded data; click No to delete the device but retain the recorded data; 
click Cancel to cancel the delete action� Please note that only those designated devices can record 
videos�

j� Click >> to add devices to the DefaultGroup� 

k� Delete recorded data older than the duration: If you only want to retain recorded data for a duration, 
check this item and enter a number of day(s)� In addition, since VAST Server will do "cyclic recording" 
automatically, the oldest file will be overwritten by the latest one when the maximum capacity is 
reached� 

l� When completed, click Apply to confirm and save your settings� If you want to cancel all of your 
editing, click Restore to return to the previous settings or click close to discard the settings�

i

i j

i

k

l
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Add New Recording Group(s)
If you want to add a new recording group, click  Add to give a name to the new recording group, 
which will be displayed on the drop-down list�
The following is an example of recording group list�

Please refer to the following limits when you set up recording group(s):
 The maximum number of devices in a recording group is 32-CH�
 One recording group can be assigned with several recording paths and do cylic recording; while one recording 

path should only be assigned to one recording group�
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How to Edit Recording Schedules
After editing recording storage settings, you can begin to edit recording schedules for the 
devices in a recording group� By default, all devices are assigned to the default recording 
schedule (Please refer to the default time frame settings on page 74)� Therefore, once you 
insert a device to the station, the VAST Server will begin to record live video according to the 
default recording schedule� You can also manually remove a device from the default recording 
schedule� Please note that you cannot assign recording schedules to those devices which 
have been deleted from a recording group�

The following is an illustration of a set of recording schedules, which are composed of several 
time frames� Each time frame has its own time segments, period of time, repeat interval, and 
recording mode� You can create different recording schedules with simple or complex time 
frames based on your needs�

In addition, you can arrange the priority of each time frame according to its importance� The 
recording schedule with the highest priority will be applied first� This capability is very useful 
because you can specify a new time frame with the highest priority temporarily without modifying 
the other time frames�

Features of the recording schedules:
 Each device can be assigned to only one recording schedule�
 Each recording schedule may contain many time frames�
 Each time frame has its own repeat frequency and recording mode�

To save time editing recording schedules and time-frames, we also provide a useful template 
function to save your time on schedules/time-frames settings. That is, you can save a specified 
schedule and download it as a template for future use or upload a well-arranged schedule 
template designed by others�

Please note that after you save the recording settings in the server, the recording schedule will 
begin automatically according to your settings�

Router 

Time Frame a 

Recording Schedule 1

Time Frame b

Time Frame n

Time Frame y

Recording Schedule N

Time Frame z

Devices in Recording Group
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Edit Schedule List

Please follow the steps below to set up the recording schedules:
a� Select the target station from the hierarchical management tree�
b� Click Configuration > Station Settings > Recording Schedule Settings on the menu bar (or right-

click the station and select Station Settings > Recording Schedule Settings)� 

c� The Recording Schedule Settings window will pop up� By default, all cameras under the station are 
assigned to Default Schedule, Default Time Frame, and Default Camera List�

Add Schedules
d� To add a new recording schedule, click Add to enter a name in the Schedule Name dialog box for the 

new schedule� Click OK to confirm the settings or Cancel to discard the settings� The new recording 
schedule will be displayed on the schedule drop-down list�

Rename Schedules
e� To rename an existing schedule, select the schedule from the schedule drop-down list and click 

Rename. A Schedule Name dialog will pop up for you to fill in a name for the new schedule. Click OK 
to confirm the settings or Cancel to discard the settings� The new recording schedule will be displayed 
on the schedule drop-down list�

Delete Schedules
f� To delete an existing schedule, select the schedule from the schedule drop-down list and click Delete� 

A Remove Schedule dialog box will pop up� Click OK to confirm or Cancel to discard the settings�

e fd

e
d

f

a

b

c

b
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Load/Save Schedule Templates
g� If you have a schedule template with time frame settings, you can upload it to simplify the editing of 

the schedule� Click Load Template, and a Load File dialog box will pop up. Select the template file 
and click Open to load� 

h� If you want to save a schedule as a template for future use, select the schedule from the schedule 
drop-down list and click Save as Template� A Save File dialog box will pop up for you to save the 
template file.

g

h

hg
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Edit Camera List

Please follow the steps below to assign a device to a recording schedule:
a� Select a recording schedule on the schedule drop-down list�
b� By default, all devices under the station are assigned to the Default Schedule�
c� Click << to remove devices from the Default Schedule� Click >> to add devices to the Default 

Schedule� 
d� Click Apply to confirm or Close to discard the settings�

If you add a Network Device that does not belong to any Recording Group, a warning dialog will pop up as shown 
below� For more information about how to set up Recording Group(s), please refer to Recording Group Settings on 
page 66�

b

c

f

a
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Edit Time Frame List

Default Time Frame: Weekly (Day-based), Mon�~Sun�, 24-hour, continuous recording

Click Edit to open the Default Time Frame settings page as shown below�
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Add New Time Frames

Please follow the steps below to add new time frames to a schedule:
a� Select a recording schedule from the drop-down list�
b� Click Add to open the Time Frame Settings window�

c� Enter a name for the new time frame�
d� If you have a time-frame template, you can upload it to simplify the editing of the schedule� Click Load 

Template and the Load File dialog box will pop up. Select the template file to load. 
e� To edit the new time frame, select a Repeat Frequency from the drop-down list and edit the time 

segments, applicable days, applicable period of time, and repeat time interval� For the detailed settings 
of each repeat frequency, please refer to The Concept of Repeat Frequency on page 77�

f� When completed, click Save to enable the settings�
g� If you want to save this time frame as a template for future use, click Save as Template� A Save file 

dialog will pop up for you to save the template�

a

b

c
d fg

e
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h� If you want to add additional time frames to the schedule, repeat the steps above� 
i. Close the window when you finish the time frame settings.
j� Back to the Recording Schedule Settings window, the new time frame will be displayed on the Time 

Frame List�
k� If you want to edit an existing time frame, select if from the Time Frame List and click Edit to set up�
l� If you want to delete an existing time frame, select if from the Time Frame List and click Delete�
m� If you want to change the priority of a time frame, select it from the Time Frame List and click Up or 

Down to shift its position� The time frame on the top of the list has the highest priority�

Recording Settings
n� Select one of the following Recording Modes for the time frame: 
     None: No recording action�
 Continuous: 24-hours continuous recording� If you want to enable Activity Adaptive Streaming, 

please refer to page 69 for detailed illustration�
 Event: The server will start to record only when an event is triggered� The recording time length 

depends on the settings in Recording Storage Settings� The default time length is 20 seconds (10s 
pre-event time plus 10s post-event time)� Please refer to page 68 for more information� For more 
information about event catagories, please refer to page 160 for detailed illustration�

o� Select Trigger Source(s): Motion Detection, IVA (Intelligent Video Analysis), PIR, and Tamper Detection
p� Select the status of Digital Input(s): Trigger State or Normal State
q� Click Apply to confirm the settings. Then close the window when you finish the recording schedule 

settings�

j
n

m

q

k l

o

p
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The following diagrams show the frame rate variation of two recording modes:
1� Continuous recording + Activity adaptive recording (helps save bandwidth and storage)

2� Event recording

The Concept of Repeat Frequency

VAST offers the following types of repeat frequency. The definition of each type is listed in the 
following table:
Repeat Frequency Discription

Daily Setting  Specify arbitrary time segments within a day,
 Repeat the segments every N days in the specified period of time.

Weekly Setting (Day-based)
(Default Time Frame)

 Specify arbitrary time segments within a day, 
 Apply only on selected days of a week,
 Repeat the segments every N weeks during the specified period of time.

Weekly Setting (Periods in a week)  Specify arbitrary time segments within a week,
 Repeat the segments every N weeks during the specified period of time.

Monthly Setting (Day-based)
 Specify arbitrary time segments within a day, 
 Apply only on selected days of a month,
 Repeat the segments every N months during the specified period of time.

Yearly Setting (Day-based)
 Specify arbitrary time segments within a day, 
 Apply only on selected days of a year,
 Repeat the segments every N years during the specified period of time.

Time

Bandwidth

Continuous Recording 
I frame   --->   Full frame rate   --->   I frame

Event Recording

Time

Bandwidth

No recording data ---> Full frame rate ---> No recording data
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Repeat Frequency: Daily Setting

To set up daily repeat frequency, please configure the following items: Daily time segments, applicable 
period of time, and repeat time interval�

Set up daily time segments

You can specify several time segments within a day� The numbers 0~23 on the hourly timeline control 
bar (the purple rectangles) represent the 24 hours in a day� 

There are two ways to define time segments: one is to use the computer mouse to manipulate the 
timeline control bars; the other is to fill in the precise start and end time values in the corresponding 
fields.

Add time segments: Choose either step 1 or step 2 to set up
1� Use the mouse to drag the timeline bars:

a� Left-click the daily timeline control bar (the purple rectangles) and drag the mouse� 
b. The corresponding time segment will also appear in the Start Time and End Time fields. Click Add, 

then the red timeline bars representing new time segments will appear as shown below� You can 
drag multiple time segments within a day� 
In the following illustration, the yellow arrows show the dragging direction of the mouse� You can 
drag from left to right or the opposite�

Daily time segments 
*You can drag the daily 
timeline bar for more 
than one time segment 
per day�

Applicable period of 
time

Repeat time interval

Daily timeline control bar



 

 

 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
User's Manual - 79  

2� Fill in the precise Start Time and End Time: 
a� Directly enter the value in the Start Time and End Time fields, then click Add�
b� The corresponding red timeline bar will automatically appear as shown below� 

Delete time segments: Choose either step 1 or step 2 to set up
1� Use the mouse to erase the timeline bar: Right-click on an existing red timeline bar and drag the 

mouse� A green timeline bar representing the deleted part of the time segment will erase the red bar as 
shown below� 

    In the following illustration, the green arrows show the dragging direction of the mouse� You can drag it 
from left to right or the opposite�

2� Use the delete button to remove the entire timeline bar: 
a� Click an existing red timeline bar or left-click the daily timeline control bar (the purple rectangles) 

and drag the mouse�
b� The corresponding time segment will appear in the Start Time and End Time fields�
c� Click Delete, and the selected timeline bar will disappear�

a b

a
c

b
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Set up applicable period of time

For repeat frequencies, you can set up the applicable date and period of time for the time frame� 
a� Specify the start date and time in the Start field. A calendar date selector will appear when you click 

on the drop-down list of date� Click  or  to select the month, then pick a desired day in the 
calendar�

b� Specify the end date and time in the End field if you have an end time for applying this time frame. If 
you do not have a terminating time for this time frame, select Never Stop�

Set up repeat time interval

The repeat time intervals is "every N day(s)" as shown below� Repeat every 1 day means the time frame 
would apply for every day within the period of time�

Click to select a year
Click to select a month from the drop-down list

b
a

Click here to move the focus to the current date 
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Repeat Frequency: Weekly Setting (Day-based)

To set up Weekly (Day-based) repeat frequency, please configure the following items: Daily time 
segments, applicable days within a week, applicable period of time, and repeat time interval�

Set up daily time segments

Please refer to page 78 for detailed instructions�

Set up applicable days within a week

For repeat frequency--"Weekly (day based)", you can apply the time segments only on selected days of 
the week�

Set up applicable period of time

Please refer to page 80 for detailed instructions�

Set up repeat time interval

The repeat time intervals is "every N week(s)" as shown below� Repeat every 1 week means the time 
frame would apply for every week within the period of time�

Daily Time segments  
*You can drag more 
than one time segment 
per day�

Applicable days 
within a week

Applicable period of 
time

Repeat time interval

Daily timeline control bar (24h)
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Repeat Frequency: Weekly Setting (Periods in a week)

To set up Weekly (Periods in a week) repeat frequency, please configure the following items: Time 
segments within a week, applicable period of time, and repeat time interval�

Set up time segments within a week

You can specify several time segments within a week� The weekly timeline contol bar represents the 
7 days of a week, and the daily timeline contol bar represents the 24 hours in a day� The daily timeline 
control bar is only valid when one of the days on the weekly timeline control bar has been selected� 

There are two ways to set up time segments: one is to use the computer mouse to draw the timeline 
control bars; the other is to fill in the precise start and end time value in the corresponding fields.

Add time segments: Choose either step 1 or step 2 to set up
1� Use the mouse to drag the timeline bars: 

a� Click on a day on the weekly timeline control bar� The selected bar will turn green�
b� Left-click the daily timeline control bar and drag the mouse� 
c� The corresponding time segment will also appear in the Start Time and End Time fields. Click Add, 

then the red timeline bars representing new time segments will appear as shown below� You can 
drag multiple time segments within a day and a week� 
In the following illustration, the yellow arrows show the dragging direction of the mouse� You can 
drag from left to right or the opposite�

Time segments within 
a week 
*You can drag more 
than one time segment 
per week�

Applicable period of 
time

Repeat time interval

Weekly timeline control bar

Daily timeline control bar (24hr)

a
b

c
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2� Fill in a precise Start Time and End Time: 
a� Directly select a day and enter the value in the Start Time and End Time fields, then click Add�
b� The corresponding red timeline bars will automatically appear as shown below�
     The following is an example of an extended time segment from Mon� 8:00 to Fri� 19:00�

Delete time segments:  Please refer to page 79 for detailed instructions�

Set up applicable period of time

Please refer to page 80 for detailed instructions�

Set up repeat time interval

Please refer to page 81 for detailed instructions�

a

b
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Repeat Frequency: Monthly Setting (Day-based)

To set up Monthly (Day-based) repeat frequency, please configure the following items: Daily time 
segments, applicable date(s) of a month/ day(s) of a week, applicable period of time, and repeat time 
interval�

Set up daily time segments

Please refer to page 78 for detailed instructions�

Set up applicable date(s) of a month/ day(s) of a week

For repeat frequency--"monthly (day-based)", you can apply the time segments only on selected days of 
a month� There are two types of repeat frequencies: Date(s) of a month and Day(s) of a week�

Daily time segments 
*You can drag more 
than one time segment 
per day�

Timeline control bar (24hr)

Applicable date(s) of 
a month/ day(s) of a 
week

Applicable period of 
time

Repeat time interval



 

 

 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
User's Manual - 85  

Repeat by date(s) of a month: 
Select date(s) from the calendar, and it will be displayed on the right blank as shown below�
The following example refers to the 1st ~ 5th day of a month�

Repeat by day(s) of a week: 
Select day(s) from the calendar, and it will be displayed on the right blank as shown below�
The following example refers to the 1st ~ 5th Friday of a month�

Set up applicable period of time

Please refer to page 80 for detailed instructions�

Set up repeat time interval

The repeat time intervals is "every N month(s)" as shown below� Repeat every 1 month means the time 
frame would apply for every month within the period of time�
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Repeat Frequency: Yearly Setting (Day-based)

To set up Yearly (Day-based) repeat frequency, please configure the following items: Daily time 
segments, applicable date(s) of a year/ day(s) of a week, applicable period of time, and repeat time 
interval�

Set up daily time segments

Please refer to page 78 for detailed instructions�

Set up applicable date(s) of a year/ day(s) of a week

For repeat frequency--"yearly (day-based)", you can apply the time segments only on selected days of a 
year� There are two types of repeat frequencies: Date(s) of a year and Day(s) of a week�

Daily time segments 
*You can drag more 
than one time segment 
per day�

Timeline control bar (24hr)

Applicable date(s) 
of a year/ day(s) of a 
week

Applicable period of 
time

Repeat time interval



 

 

 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
User's Manual - 87  

Repeat by date(s) of a year: 
Select date(s) from the calendar, and it will be displayed on the right blank as shown below�
The following example refers to the 1st ~ 5th day of a year�

Repeat by day(s) of a week: 
Select day(s) from the calendar, and it will be displayed on the right blank as shown below�
The following example refers to the January 1st ~ 5th Friday of a year�

Set up applicable period of time

Please refer to page 80 for detailed instructions�

Set up repeat time interval

The repeat time intervals is "every N year(s)" as shown below� Repeat every 1 year means the time 
frame would apply for every year within the period of time�
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How to Manually Begin /Stop Recording
By default, all devices are assigned to the default recording storage and default recording 
schedule� Therefore, once you insert a device onto the station, the VAST Server will begin 
to record live video according to the default recording schedule� Please refer to How to Edit 
Recording Schedules on page 70�

However, if you have changed the default schedule, you can manually click Manually Begin 
Recording to enable a device without setting up a recording schedule� Please follow the 
instructions below to manually begin recording�

Select the device from the hierarchical management tree under Default Group, then click Edit 
> Manually Begin Recording on the menu bar (or right-click the device and select Manually 
Begin Recording)� The string on the menu bar will turn into Manually Stop Recording as 
shown below and the VAST Server will start to record video from the target camera� Please 
note that its priority will be higher than the recording schedule, so it will continue unless you 
click Manually Stop Recording. After you click Manually Stop Recording, the device will then 
follow the preset recording schedule�
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How to Edit Scheduled Backup Settings
VAST LiveClient supports scheduled backup which allows the user to back up the recorded data 
in another disk�
Please follow the steps below to enable scheduled backup settings:
a� Select the target station from the hierarchical management tree�
b� Click Configuration > Station Settings > Scheduled Backup Settings on the menu bar (or right-

click the station and select Station Settings > Scheduled Backup Settings)�

c� The Scheduled backup settings window will pop up�

Select Backup Source
d� Check Enable schedule backup�
e� Select the data source you want to backup� If you check Selected cameras, you can click >> or << to 

choose the data source that you want to backup�

d
e
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Setup Backup Schedule
f� Fill in a desired time and click >> to add the backup time� Please note that the backup time interval 

must not less than 1 hour� For example, 23:40 and 00:15 are not allowed to exist simultaneously� 
   In the following example, the server will backup the recorded data at 12:00 PM and 23:00 PM everyday 

once you save the settings� 

The following diagram shows the backup schedule and backup data:

Select Backup Target
g� Click Browse... to select a path (local path or network storage) to store the backup data� Please 

note that the disk for backup data should be different from the original recording path, or a warning 
message will pop up as shown below� For more information about how to set up recording path, please 
refer to page 67�

h� Select a maximum size for backup folder� The server will divide backup data into the following size: 
VCD (650M), DVD (4�7G), Customize, or Unlimited size according to your choice�

i� Select Delete old backups if space is insufficient if you want to do cylic backup due to the limited 
size of the hard disk�

Other Options
j� If you only want to backup the recorded data of events, select Backup only events and fill in the pre- 

and post-event time�

g
h
i

Server 
start 12:00

2010/01/24
23:00

2010/01/24
12:00

2010/01/25
23:00

2010/01/25

2nd backup 
data

1st backup 
data

3rd backup 
data

4nd backup 
data

f

j
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How to Configure Station Server Settings
VAST LiveClient supports Server Settings including DDNS Settings, Network Storage Settings, 
and SMTP Settings�
Select the station from the hierarchical management tree and click Configuration > Station 
Settings > Server Settings to open the page (or right-click the station and select Station 
Settings > Server Settings)�

DDNS Settings

Since the public IP of VAST Server may be a dynamic IP address, DDNS service will give it a 
fixed domain name. 
Select a DDNS provider from the provider drop-down list� VIVOTEK offers 2bthere�net (Safe100�
net), a free dynamic domain name service, to VIVOTEK customers� Please refer to the user's 
manual of VIVOTEK's network camera for detailed DDNS settings�
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Network Storage Server Settings

The VAST Server allows user to set up network storage path(s) for recorded files. Please follow 
the steps below to add a new network storage path�
a� Click Add to open the Network Host Window�
b� Fill in the related information for the network host� Then click OK to save the new settings�

c� If you want to add more network host(s), please repeat step a� b�

a

b
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SMTP Settings

VAST Server allows user to set up SMTP Server to send mail alert when event triggers� For 
more information about how to set up event management, please refer to page 51�
Please follow the steps below to configure the SMTP Server:
a� Click Add to open the SMTP Settings page�
b� Enter the related information of your mail server� If your SMTP server requires a secure connection 

(SSL), check Use SSL�
c� Click OK to enable the settings�
d� Then the new information will appear on the SMTP Settings window as shown below�

b

a

c

d
If you have more than 
one SMTP server, you 
can click to arrange the 
priority.
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How to Use the Talk Panel
VAST LiveClient supports the two way audio function which allows the user to communicate with 
people around the network camera� Please enable the two way audio function on the camera 
side�
The following is an illustration of the two way audio function:

Add a Camera to the Talk Panel

 There are several ways to add a Network Camera to the Talk Panel:
Drag-and-drop a camera from the video cell or from the hierarchical management tree to the talk panel 
as shown below� You can also right-click the target camera or the video cell, then click Send to Talk 
Panel on the popup menu� 

Audio transmitted from operators

Audio transmitted from network camera

Network Camera with internal 
or external microphone
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 An icon with the camera name will be displayed in the Talk Panel� 

 Please note that you cannot Talk  and Play Sound  at the same time�
 When you are talking or playing sound, you cannot add other cameras to the Talk Panel� If you want to add more 

cameras to the Talk Panel, please Stop Talking  and Stop Playing  first�

Click to stop talking Click to stop playing

Remove all cameras 
from the Talk Panel

Click to play sound from the camera

Click to talk

Click to adjust volume

Click to play the selected 
sound on the client side

Select sound from the 
file list



 

 

VIVOTEK - A Leading Provider of Multimedia Communication Solutions

 
96 - User's Manual

 

 

Remove a Camera from the Talk Panel

 Remove a camera
   Drag a camera from the Talk Panel and drop to the hierarchical management tree window as shown 

below� The camera icon will disappear�

 Remove all cameras
   Click  , all cameras in the Talk Panel will be removed�
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How to Configure E-map Settings
VAST LiveClient supports intuitive E-map function which allows users to upload E-maps for 
overall devices management�
Click System > E-map to open E-map Settings Page:

Upload an E-map

Click  to search for E-map(s) to upload� 

The uploaded E-maps will be listed under the E-map list tree�

If the uploading procedure fails, please compress the image size of your map (< 5MB) and try again�
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User Interface of E-map Settings Page (View Mode)

 Double-click an E-map on the tree, it will be displayed on the E-map window as shown 
below� There are two operation modes of E-map settings page: "View Mode" and "Edit Mode"� 
The following is the "View Mode" illustration�

A� Menu bar        B� Quick access bar        C� E-map list tree        D� E-map window        E� Status panel

 Right-click the E-map, then you can edit, rename, or delete the E-map�

B

A

C

ED
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 Right-click an E-map on the tree and click Edit or click  on the Quick Access Bar, it will 
switch to edit mode�

Quick Access Bar

Status Panel

Icon Function Description

Zoom in Zoom in the E-map

Zoom out Zoom out the E-map

Default size Adjust the E-map to default size

Upload Upload E-map to the login station

View Mode Click to switch to view mode

Full Screen Extend the E-map settings page to full screen

Save Save E-map settings

User Name
Station Name (IP Address)
Login Time (yyyy-mm-dd hh:mm:ss)
Current Time (yyyy-mm-dd hh:mm:ss)
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User Interface of E-map Settings Page (Edit Mode)

A� Menu bar          B� Quick access bar          C� E-map list tree         D� Device tree          
E� Map preview        F� E-map window        G� Status panel

 Right-click the E-map, you can download, rename, or delete the E-map�

B

A

C

D

E

GF

Download the E-map to E-map window
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Device Management

Please follow the steps below to edit an uploaded E-map�
a� Double-click the E-map you want to edit, it will be displayed on the E-map window� 
b� Use Quick Access Bar to adjust the size of the E-map� In edit mode, you can also use your mouse to 

drag the position of the E-map and zoom in or zoom out the E-map�
c� Drag-and-drop the connected devices to the E-map according to your deployment�

 

d� Right-click the device icon on E-map, you can rotate the direction or delete the device� The device 
can be rotated in 8 derections as shown below�

e� You can also drag the DI/DO device under the connected device onto the E-map� If you want to 
change the status of the DO device, double click the DO icon on E-map�

    

f� Click  on the Quick Access Bar to save the new settings�

b

c

// Digital input on / off

// Digital output on / off

The red frame twinkling around the device means there is event trigger(s) going on�
Meanwhile, a live view dialog will pop up beside the model�

For more information about DI/DO settings, please refer to 
Association Management on page 49�
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Live View Dialog Settings

Click Configuration > E-map Settings to open the E-map Settings dialog, then you can 
choose to Open Live View Dialog or to Send to Single View when you double-click the device 
deployed on the E-map�

Open Live View Dialog

Select Open Live View Dialog: When you double-click the device icon on the E-map or when an event 
triggers, a live view dialog will pop up beside it� It is the default setting in E-map Settings window�

Send to Single View

Select Send to Single View: When you double-click the device icon on the E-map, it will open a single 
view on the VAST LiveClient�

If you have set up dual monitor, it will be automatically sent a single view to the second monitor�
Monitor 1 Monitor 2
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E-map Link

After completing device deployment on your E-map, you can link an E-map to another E-map�
Please follow the steps below to configure E-map link:
a� Select a map you want to edit and enter Edit Mode�

b� Drag-and-drop another E-map onto current E-map� A blue frame will appear as shown below�
    For example: Link Map1 to Map2 by dargging Map2 onto Map1

c� Use   to move the position of the blue frame�

The live view dialog also supports click on image, PTZ, and e-PTZ  as long as the linked device supports and 
enables those functions� To enable those function on E-map, please check the item "Enable click on image" on the 
menu bar of LiveClient as shown below� Then an icon  will appear in the live view dialog for you to control the 
cameras�
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d� Right-click the blue frame to Resize or Delete it� 

   Click Resize, some nodes will appear around the blue frame� Then You can drag the nodes to move 
the position, rotate the direction, adjust the size, and change the shape�

e� Click  on the Quick Access Bar to save the new settings�

f� If you want to set additional map links, please repeat steps a� ~ e�
   For example: Link Map2 to Map3 by dargging Map3 onto Map2

g� Click  on the Quick Access Bar to save the new settings�

resize change the shape
rotate the direction

move the position
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h� Test the web links� Click  on the Quick Access Bar to switch to view mode� 
    Double-click the blue frame on Map1, it will automatically switch to map2� Then double-click the blue 

frame on Map2, it will automatically switch to map3�

Map 1

Map 2

Map 3
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How to Configure Client Settings
In Client Settings, you can configure Snapshot Settings, Recording Settings, View Settings, 
General Settings, Joystick Settings, Proxy Settings, and PiP Settings�

 

Snapshot Settings

Please follow the steps below to configure snapshot settings:
a� Click Configuration > Client Settings > Snapshot Settings on the menu bar to open the Snapshot 

Settings window� 
b� Select a picture format for snapshots (BMP or JPEG)� If you select JPEG format, you can adjust the  

recompression quality (from 1 to 100)� Note that a higher value would generate higher picture quality 
but lower compression rate�

c. Fill in a filename prefix for the snapshots.
d. The default storage path for snapshots is C:\Program Files\VIVOTEK Inc\VAST\Client\LiveClient\

Snapshot� If you want to change the storage path, click Browse  to select another folder�

e� If you check Generate a file name automatically, VAST will directly save snapshots with the following 
filename format to the storage folder. 

b
c

d

Snapshot_20100125_173015_01�jpg

File name prefix Date and time 
(YYYYMMDD_hhmmss) 

Serial number of snapshots

Picture format

e
The recompression quality is only 
enabled in MPEG-4 streaming� If your 
stream source is MJPEG, the system 
will directly save the JPEG image 
without recompression� 
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If you uncheck Generate a file name automatically, the Save file dialog box will pop up when you 
take a snapshot. The file name prefix will automatically be displayed in the Save File dialog box.

Take a Snapshot

Please follow the steps below to take a snapshot of the live video stream:
a� Select the video cell of which you want to take a snapshot�
b� Click Snapshot  on the quick access bar, or right-click the video cell and select Others > 

Snapshot from the popup menu� You also can click Edit > Snapshot to take a snapshot�

c� The snapshots will be found in the preset storage folder on your local computer�
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Recording Settings

The VAST Server allows you to record the live video in EXE, 3GP, or AVI format to your storage 
folder�

Type 1: Record to EXE 
Record video as an EXE file. The EXE is not only a media file but also a built-in media player. When 
user execute the EXE, the media file will be played automatically. There is no need to install any other 
program� For more information about how to use the EXE player, please refer to page 112�

Please follow the steps below to configure EXE record settings:
a� Click Configuration > Client Settings > Recording Settings on the menu bar to open the Recording 

Settings window�
b� Select EXE as the Record Type�
c. The default storage path is C:\Program Files\VIVOTEK Inc\VAST\Client\LiveClient\Record. If you want 

to change the storage path, click Browse  to select another folder�
d� Select the Length of each file-- Maximum Size (10~2000MB) or Maximum Time Interval (1~150 

min)� 

e� Click OK to enable the settings�

Type 2: Record to 3GP
Record video as a 3GP file. 3GP file is a standard MP4 format compatible with players such as VLC, 
QuickTime, or Real players� Choose this type if you has already installed one of these players�

Please follow the steps below to configure 3GP record settings:
a� Click Configuration > Client Settings > Recording Settings on the menu bar to open the Recording 

Settings window�
b� Select 3GP as the Record Type�
c. The default storage path is C:\Program Files\VIVOTEK Inc\VAST\Client\LiveClient\Record. If you want 

to change the storage path, click Browse  to select another folder�
d. Select the Length of each file-- Maximum Size (1~2000MB) or Maximum Time Interval (1~150 min)�

b

c
d
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e� If you check "Record with only standard codec", the video from old models (VIVOTEK 6000-series 
products) using G7221/G729A/H�263 codec will not be recorded�

f� Click OK to enable the settings�

Type 3: Record to AVI
Record video as an AVI file, which uses the popular codecs pre-installed in the Windows OS. Please 
note that the speed may be slower due to the need of decoding the video/audio and re-encoding both 
into a compatible codec�

Please follow the steps below to configure AVI record settings:
a� Click Configuration > Client Settings > Recording Settings on the menu bar to open the Recording 

Settings window�
b� Select AVI as the Record Type�
c. The default storage path is C:\Program Files\VIVOTEK Inc\VAST\Client\LiveClient\Record. If you want 

to change the storage path, click Browse  to select another folder�
d. Select the Length of each file-- Maximum Size (1~2000MB) or Maximum Time Interval (1~150 min)�

b

c
d

e

b

c
d

e
f g

Due to the AVI file has a limitation on 
the maximum file size of 2G bytes, 
if the setting “time length” generates 
data larger than 2G bytes, several 
files will be created.
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e� Select the frame rate/ per second� 
f� To modify the video compression settings, click Video Compression Setting to open the AVI Video 

Compression Setting window� Select the desired video compression algorithm, compression 
quality, key frame intervals, and data rate in the corresponding fields.

 To modify the settings of the compression algorithm: Click Configure, then a dialog box will pop 
up for you to modify the settings� The dialog box will be different according to the compressor you 
select� 

 To read the information of a compression algorithm (its version for instance): Click About, and a 
dialog box will pop up showing the related information� The dialog box will be different according to 
the compressor you select�

g� To modify the audio compression settings, click Audio Compression Setting to open the AVI 
Audio Compression Setting window� Select the desired audio quality, format, and attributes in the 
corresponding fields.

If you do not choose to compress the video, 
the generated AVI file will be very large.
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Record an EXE/3GP/AVI File

Please follow the steps below to record an EXE/3GP/AVI file of a live video stream:
a� Select a video cell or a device from the heirarchical management tree which you want to record to 

media file.
b� Click Record to EXE/3GP/AVI  on the quick access bar, or right-click the video cell and click 

Record to EXE/3GP/AVI� You can also click Edit > Record to EXE/3GP/AVI on the menu bar� (The UI 
string will change according to your Recording Settings�)

c� For recording a high-resolution video (1600 x 1200) in AVI type, a dialog box will pop up as shown 
below to remind you that the CPU loading will increase� Click OK to continue the process�

d� The icon  will then change to Recording EXE/3GP/AVI , and a red text string (EXE/3GP/AVI) 
will appear at the bottom right of the video cell� Note that only one video channel can be recorded at a 
time�

e� When you want to terminate the AVI Recording, click the icon  on the Quick Access Bar� The export 
process will then terminate and the button will change from  to . The recorded media files will be 
found in the preset storage folder on your local computer as shown below� 

    Below is the file name format for AVI files:

AVI

20100125_173015�avi

Date and time 
(YYYYMMDD_hhmmss) 

Video format
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Built-in Media Player--EXE

The following is the icon of EXE� Double-click it, the recorded video will be played automatically as 
shown below�

Icon Function Description

Pause Pause playback of the focused video clip

Play Start playback of the focused video clip

Stop Stop playback of the focused video clip

Next Frame Go to the next video frame of the focused video clip

Slow Down Slow down the playback rate

Speed Up Speed up the playback rate

Control Buttons

Timeline Slider

Status Panel

Current time of the video clip

Total length of the histogram

The playing rate can be 1/8, 1/4, 1/2, 1X, 2X, 
4X, 8X, 16X, 32X, and 64X�

Video Title
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The function menu of the built-in media player are displayed as shown below:

 The built-in player is able to playback 3GP and EXE files.
 The built-in player is able to save 3GP files as EXE files.
 The built-in player is able to save EXE files as 3GP files.
 The built-in player is able to convert EXE and 3GP files into AVI files.
 The built-in player also supports snapshot and print functions�
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View Settings

This section allows you to set the display mode of a video cell, including Display Location, 
Date and time Format, Video Display Mode, and Font Settings� When you change the 
settings, the sample window will change accordingly for you to preview the settings� 

Display Location

As the illustration shows, there are 4 display areas for you to input information about the live video� Each 
drop-down list includes 6 options for you to select: No display, Camera Name, Video Title, Camera 
Date, Camera Time, and Camera DateTime. 

Display Area 1 Display Area 2

Display Area 3 Display Area 4
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Date and Time Format

 Same as local computer: Select this option and then the date and time format will synchronize with the 
local computer�

 Specify: Select a desired format for the date and time from the drop-down list� 
   Date format: Select YYYY/MM/DD or MM/DD/YY�
   Time format: Select the default time format (synchronize with the local computer), 12h AM/PM, or 24h�

Video Display Mode

 Show motion window when triggered: If you select this option, the red frame of the motion detection 
window will appear in the video window when motion is triggered� This function is enabled as default�

For detailed information about how to set up the layout of the live view window, please refer to How to 
Change Video Viewing Mode on page 31�

Font Settings

This function allows you to change the font on the video cell�

 Font: Automatically lists all fonts installed on your operating system� Select the desired type�

 Color: Select a desired font color (white, red, green, blue)�

 Size: Select a desired font size (8, 10, 12, 14)�

 Keep the aspect ratio: In the default settings, the size 
of the video window will change according to the 
layout of the live view window you choose� However, 
the frame size may be distorted� If you select Keep 
the aspect ratio, the video window will be adjusted 
to the same frame size as the preview window� This 
function is disabled as default�
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General Settings

This section allows you to configure the System Settings and Rotation Settings�

System Settings
  Auto login after logging in to operating system: If you check this option, VAST LiveClient will 

automatically login after you login to Windows without filling in the user name and password� This 
function is disabled as default�

  Automatically display in full screen after login: If you check this option, the video cells will be displayed 
in full screen without showing the menu bar or the control panels� 

  Auto add newly-inserted camera to video cell: If you check this option, VAST LiveClient will 
automatically add the newly-inserted device to a video cell� This function is enabled as default�

  Retrieve RTSP streaming on specific port: The default port for RTSP streaming is 554� If you want to 
change this port, please check this item and fill in a desired port�

  Setup substation streaming connection by relaying: This option is not checked by default� As the 
following diagram shows, VAST Client might directly connect to the streaming under VAST Server 
3-2 without requesting the connection via VAST Server 1 and Server 2-1� If you want to get streaming 
through relaying, please check this option� 

 If the VAST Server 3-2 is set up behind a firewall, the VAST Client will not be able to access the VAST Server 3-2 
directly� You have to get the connetion by relaying�

VIVOTEK IP CameraVIVOTEK IP Camera

ST7501
Server 3-1

VAST
Server 1

VAST
Client

VAST
Server 2-1

VIVOTEK IP CameraVIVOTEK IP Camera

VAST
Server 3-2

VIVOTEK IP CameraVIVOTEK IP Camera

VIVOTEK IP CameraVIVOTEK IP Camera

ST7501
Server 3-3

VAST
Server 2-2

VIVOTEK IP CameraVIVOTEK IP Camera

ST7501
Server 3-4

manages 2 sub-stations
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Event Settings
  Enable live event notification: Select this option to activate real-time event notification� For example: 

the event notification of DI/O status on the hierarchical management tree, the event list in the event 
window, motion detection windows in video window, or the event notification on E-map settings page, 
etc� This function is enabled as default�

  Enable alert sound(s): If you enable this option, you will hear alert sound on the client side when the 
event is triggered��

  Event window mode: Select Fixed or Popup mode for the event window� For more information about 
event window, please refer to page 17�

Rotation Settings
  Enable rotation after login: If you check this option, the video cells will start to rotate after you login to 

the VAST LiveClient� The default setting of this function is disabled�
  Rotate the page every  second(s): Fill in a desire interval time for video page rotation� The maximum 

value is 99 seconds� The default value is set at 6 seconds�

For detailed information about how to set up the layout of the monitoring window and rotation functions, 
please refer to How to Change Video Viewing Mode on page 31�

Display Settings
  Enable de-interlace function: Select this option if your connected device does not support de-interlace 

function� For example: VS7100�
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Joystick Settings

This section explains how to remote control connected network devices with a USB joystick� It’s 
easy to install and configure via the USB interface.

Enable Joystick
Connect to the USB plug of the joystick to a USB port on your computer� Supported by the plug-in in the 
main page (Microsoft’s DirectX), once the plug-in in the main page is loaded, it will automatically detect if 
there is any joystick on the computer� The joystick should work properly without installing any other driver
or software�

Then you can begin to configure the joystick settings of connected devices. Please follow the instruction
below to enable joystick settings�
a� Select the target device from the hierarchical management tree�
b� Click Configuration > Client Settings > Joystick Settings on the menu bar to open the Joystick 

Settings window� If your joystick is working properly, it will be displayed on the drop-down list� 
c� Select the joystick you want to configure. Check Enable Joystick, then click Configure Buttons to 

open Buttons configuration window.

a

b

c
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Buttons Configuration
In Button Configuration window, the left column shows the actions you can assign, and the right column 
shows the functional buttons and assigned actions� The number of buttons may differ from different 
joysticks� 
Please follow the steps below to configure your joystick buttons:
a� Choosing one of the actions and click Assign will pop up a dialog� Then you can assign this action to 

a button by pressing the joystick button or select it from the drop-down list�   
    For example: Assign Home (move to home position) to Button 1� 

b� Click OK to confirm the configuration.
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c� The Assigned Action will appear beside Button 1 in the right column as shown in the following diagram� 
Note that a button can only be assigned with an action� If you want to modify the settings, select the 
action on the list and click Clear Selected�

d� If you want to assign additional actions, repeat step a�~c� When all settings are complete, click OK to 
save the settings or click Cancel to discard the settings�
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e� Click OK to save the settings or click Cancel to discard the settings�

 If you want to assign Preset actions to your joystick, the preset locations should be set up in advance� 

 If your joystick is not working properly, it may need to be calibrated� Click Calibrate  to open the Game Controllers 
window located in the MS Windows control panel and follow the instructions for trouble shooting� For more 
information, please refer to the MS Windows help files for details.

 The joystick will appear in the Game Controllers list in the Windows Control Panel on your computer� If you want 
to check out your device, go to the following page: Open Start > Control Panel > Game Controllers�
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PTZ/ E-PTZ Function
In addition to using the PTZ control panel, you may also control the rotation handle of the joystick to 
remote control a PTZ/ E-PTZ network camera with ease�

Pan/Tilt: Move the rotation handle of the joystick; you can pan the camera to the desire position� There 
will be blue line displaying the moving direction in the center of the video image as the diagram 1 below�

Zoom in/Zoom out: Shift the rotation handle clockwise to zoom in the camera on an image or go 
counterclockwise to zoom out the camera on an image� There will be a circle and four vectors in the 
center of the video image as the diagram 2, 3 below�

Proxy Settings
In this section, you can enable, modify, or cancel Proxy Settings for client if your VAST Server 
is under a proxy. If you change the proxy settings, please fill in the new value next time you login 
the LiveClient next time�

Zoom in
(Turn the rotating handle clockwise)

Zoom out
(Turn the rotating handle counter-clockwise)

Pan/Tilt
(Move the rotating handle back and forth)

FD8161 FD8161 FD81612010/09/03 PM 03:56:17 2010/09/03 PM 03:56:17 2010/09/03 PM 03:56:17
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How to Use PiP (Picture-in-Picture)

PiP (Picture-in-Picture) is an intuitive function for user to simultaneously view a Global View and 
ROI (Region of Interest) for live monitoring� The digital zoom in function can only focus on the 
interested area and represent the details of megapixel video� Moreover, the multi-touch mode is 
a very user-friendly interface for digital zoom in�  

Enable PiP
Right-click the video cell and select Enable PiP� If you want to disable PiP, click the option again to 
uncheck it� After you enable the PiP function, a movable global view window and a ROI frame will be 
displayed as shown below�
 

Global View
The global view is the original view with the size scaled down to 160x120� It is movable and you can drag 
it anywhere in the live view window� If you want to hide the global view, right-click the video cell and 
select Hide Global View from the menu� An icon  will appear on top of the live view window� 

Region of Interest
(ROI)

Global View
Digital Zoom In
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ROI (Region of Interest)
The ROI frame is capable of being resized and dragged in any direction upon the global view window as 
e-PTZ function� 

Digital Zoom In
Through digital zoom in, the live view window will be filled with the zoomed in ROI image. The maximum 
magnification of the ROI frame is 16x zooming. The zoomed in area will change as the ROI frame is 
dragged and resized� You can also easily zoom in and zoom out the ROI frame by rolling the mouse back 
and force�

Snapshot & Print Zoomed In Image
You can snapshot and print the zoomed in image�

PiP Settings
The PiP Settings is for you to adjust the initial position of the global view window� 
Click Configuration > Client Settings > PiP Settings to open the window� On top of it, you may choose 
the horizontal position with left / middle / right side of the live view window, or you can customize the 
percentage of space distance from the border of the live view window as an option� It is also fully applied 
for vertical position with top / middle / bottom side of the live view window� When it’s done, you may click 
on Apply to existing windows to enable the settings�

   If the position of ROI and global view will be saved and applied for the next open� It will be removed when the live 
view cell is removed� 

   The PiP function is also applied in VAST Playback�
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Multi-touch Mode
VAST also supports advanced multi-touch mode for PiP� You can easily zoom in or zoom out the image 
by touching the multi-touch monitor with two fingers.
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How to Configure Video Enhancement

The LiveClient allows you to enable post-image enhancement and defog for video live view�

Basic Image Adjustment

This function allows you to configure basic image adjustment including Brightness, Contrast, 
Saturation, and Hue�

Please follow the steps below to set a profile for post-image adjustment settings:
a� Select the target video cell�
b� Click Configuration > Video Enhancement > Basic Image Adjustment > Settings on the menu 

bar to open the Profile Settings window� (Or you can right-click the video cell and select Video 
Enhancement > Basic Image Adjustment > Settings from the popup menu�)

a

b

b c� Adjust the values of Brightness, Contrast, Satura-
tion, and Hue� You can preview the image from the 
window on the right� A “VE (Video Enhancement)” 
text string will appear at the bottom right of the 
preview window�

d� When completed, click Save as Profile and enter 
a name for the new profile.

e. The new profile will be displayed on the drop-down 
list. This profile can be applied to all video cells.

f� If you decide to apply the selected profile to the 
target video cell immediately, click the OK button� 
Otherwise, click Cancel to close the window�
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g� Back to the main page, a “VE” text string will also appear at the bottom right of the video cell and the 
new profile will also appear and be selected on the popup menu as shown below.

c

e

fd

g

Click to create a new profile, edit 
or delete a customized profile

Click to disable VE on all linked 
devices 
Click to enable VE on all linked 
devices 
Click to enable/disable VE on the 
target video cell 

Click to create a new profile, edit or delete a 
profile

Click to enable/disable VE on the target video 
cell 
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Defog

This function allows you to configure post-image defog.

Apply a Preset Defog Profile
Please follow the steps below to set post-image defog settings:
a� Select the target video cell�
b� Click Configuration > Video Enhancement > Defog or right-click the video cell and select Video 

Enhancement > Defog� 
c. There are some preset profiles for you to apply to the target video cell. You can select one from the list 

accoding to the environment� 

a

b

b

c

c
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d. The string of the selected profile will be selected as shown below. A “VE” text string will also appear at 
the bottom right of the video cell�

Create a New Defog Profile
e� Click Settings on the popup menu to open the Profile Settings window� 

d

d

Click to create a new profile, edit or 
delete a customized profile

Click to disable VE on all linked devices 

Click to enable VE on all linked devices 
Click to enable/disable VE on the target 
video cell 

e

e

Click to enable/disable VE 
on the target video cell 

Click to create a new profile, 
edit or delete a profile
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f� Adjust the values of Block Size, Strength, and Threshold� You can preview the image from the right 
window� A “VE (Video Enhancement)” text string will also appear at the bottom right of the preview 
window�

    Block Size: Brush diameter from thick to thin (Value 1~5)
    Strength: Brush stroke from soft to strong (Value 1~5)
    Threshold: Brush pixel from loose to dense (Value 0~225)
g� When completed, click Save as Profile and enter a name for the new profile.
h. The new profile will be displayed on the drop-down list. This profile can be applied to all video cells.
i. If you decide to apply the selected profile to the target video cell immediately, click the OK button� Oth-

erwise, click Cancel to close the window�

f

h

i
g
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How to Search for a Device on the Hierarchical Management Tree

This function allows you to conveniently search for an inserted device, which is useful when 
many devices have been inserted�
Please follow the steps below to find a device on the camera list:
a� Click the station on the hierarchical management tree�
b� Click Edit > Find on the menu bar (or right-click the station and click Find)� 

c� The Find window will pop up for you to set your search criteria�
 Find what: Enter a string in the blank� The string can be the full or partial name of the device you want 

to search for�
 String Options: Match case represents that the search results should be identical to the string in 

lower-case or upper-case letters, the string can be part of a word� Match whole word means that 
the search results should be identical to the string for every character, and that the string should be a 
complete word or phrase� If you select both options, the search results should conform to all criteria 
listed above�

 Direction: Select search up or search down�
 Search in: Select search in station or camera�

d� Click Find Next, the seaching result will be marked as shown below� 

e� If there is nothing found in the camera list, a message will pop up as shown below:

Search upSearch down

a

b c

Search results d

b
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How to Print a Video Image

There are two ways to print out an image of live video:
1� Select a video cell, then click Print  on the quick access bar, or right-click the video cell and select 

Print from the popup menu� A Print window will pop up for you to choose the printer�

2� You can also click Edit > Print to print out an image from a video�
  Focus Cell: Print out an image of the target video�
  All Cells: Print out an image with all video cells in the monitoring window�

How to Lock LiveClient for Security Concerns

If you are away from your computer, for security reasons, we suggest you lock the program� 
When LiveClient is locked, the user must fill in the correct password to unlock and access the 
program again�
 To lock LiveClient, click Unlock  on the quick access bar or click System > Lock on the system 

menu� The Unlock  icon will then turn into Lock � 
 To unlock LiveClient, fill in the correct password in the popup window�
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How to Log out from the VAST Server

To logout from the current server, click Logout  on the quick access bar or click System > 
Logout on the menu bar. A confirmation window will pop up. Click OK to confirm or Cancel to 
return to the VAST LiveClient window�

How to Exit VAST LiveClient

To exit VAST LiveClient, click Exit  on the quick access bar or click System > Exit on the 
menu bar� A confirmation window will pop up� Click OK to confirm or Cancel to return to the 
VAST LiveClient window� When you exit the program, your user account will be automatically 
logged out from the current server�
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VAST Playback Configuration
Activating VAST Playback and Logging in to a Server

VAST Playback allows you to search and playback recorded media data from VAST Server�
Once you insert a device into the hierarchical management tree of VAST LiveClient, it will 
automatically be displayed on the hierarchical management tree of VAST Playback� You can 
then begin to use VAST Playback to view recorded or backup video clips�
After installing the VAST Playback program, please follow the steps below to activate VAST 
Playback:
1� Run the VAST Playback program� If you have already run VAST LiveClient, you can also click System 

> Launch Playback to activate VAST Playback�
2� A Login window will pop up� Fill in the information as shown below:
 If you want to login to a remote VAST Server, enter the IP address, user name, password and 

communication port of the server� Click Log in to login the target server or Cancel to exit the 
system�

 If you want to login to your local host which is running VAST Server, check the Login local 
station checkbox, and the local IP Address will be displayed automatically� Enter the User Name, 
Password, and Communication Port of the local server to log in� Click Login to log in to the target 
server or Cancel to exit the system�

3� The VAST Playback main window will be displayed�

  If your network environment need to set up proxy, click More >>  to extend the login window, then click Proxy 
Setting  to open the dialog� Then enter related information to link to your proxy server�

  Available functions of the VAST Playback program will be enabled according to the role of your login account� For 
more details about the privileges of the user account, please refer to How to Manage User Accounts  on page 
44�
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VAST Playback User Interface

A� Menu bar        B� Quick access bar        C� Query panel (Browsing / Time search /Event search / Log 
viewer)        D� Status panel        E� Recorded video playback window        F� Playback control panel   
G� Video clips list    

Menu Bar

Status Panel

Menu Item Drop-down Options

System Lock / Language / Launch LiveClient / Logout / Exit

Edit Snapshot / Print / Find

View Backup Status /Exporting Status / Time Search / Event Search / Log Viewer / 
Full Screen / Minimize

Configuration Client Settings (Snapshot Settings / Export Settings / View Settings / Proxy 
Settings / General Settings)

Layout Change Layout

Help About

User Name
Station Name (IP Address)
Login Time (yyyy-mm-dd hh:mm:ss)
Current Time (yyyy-mm-dd hh:mm:ss)

G

D

A

E

B

C

F
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Quick Access Bar

Some buttons will be disabled if the selected device does not support those functions�

Recorded Video Playback Window

The "VIVOTEK" logo indicates that no camera has been assigned to the video cell� 

Icon Function Description

Exit Exit the system

Logout Logout from the current station

Lock Click to Lock the system for security concerns (  Unclock the system)

Volume Adjust the audio volume of the target video (  Mute)

Snapshot Capture the picture of the target video

Print Print out the picture of the target video

Remove All Connection Remove all live videos from the live video monitoring window

Layout Change the layout of video monitoring window

Full Screen Maximize the live video monitoring window

Switch Screen Switch to another screen

Synchronous Playback Click to enable synchronous playback for multiple channels

The red frame (  ) represents the focused cell�

Video Cell
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Language Selection

VAST current supports user interfaces in multiple languages; and language options are availabe 
in: English, Deutsch, Español, Français, Italiano, 日本語, Português, 簡体中文, and 繁體中文� 
If you want to select another language for the interface, please click System > Language on 
the menu bar to select a desired language� Please note that if you want to change the language 
option, a message will remind you to restart the system�

Query Panel-- Browsing Page

Dates with recorded 
video clips

Devices listed 
under the root 
station

If you want to use "User Defined" language, please prepare images and 
language strings, and upload the files to the following folders:

...\VAST\Client\Playback\language\zz_UD (language string)

...\VAST\Client\Playback\image (images)

Local Database

Root Station Name (IP address)

Sub-station Name (IP address)

Devices listed 
under the sub-
station
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Icon Description

Station list including server and local database

A station (a computer that has installed VAST Server)

A station (a computer that has installed ST7501 Server)

The camera that exists on the hierarchical management tree of LiveClient�

The camera that has been removed from the hierarchical management tree of 
LiveClient (off-line)� However, its recorded video (if any) is still accessible from 
the server�

Dates with recorded video clips�

Local database for backup data� For more information about how to upload 
backup data to the list, please refer to page 156�
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Query Panel--Time Search Page

The Time Zone  is the same as your local computer�

Select station(s)/ device(s) that 
you want to search for recorded 
files

Specify search period of time

Click to start to search, the 
results will be shown on the 
video clips list
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Query Panel--Event Search Page

Select an Event Category

Specify search period of time

Click to start to search, the 
results will be shown on the 
video clips list

Click to add search criteria

Click to remove search criteria

Select station(s)/ device(s) that 
you want to search for recorded 
files
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Query Panel--Log Viewer Page

Select a Log Category

Select a User Account

Select a Result Type

Select a Log Type

Select a Log Level

Specify search period of time

Click to start to search, the 
results will be listed on the 
video clips list

Select station(s) that you want 
to search for recorded logs
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Video Clips List Window

If you select a option “date”, the video clips will be displayed in the video clips list window� A 
option “date” may contain more than one video clip�
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Playback Control Panel

When you double-click a video clip to play, the playback control panel will be enabled for you to 
use�

Icon Function Description

Histogram Zoom In Zoom in on the displayed period of time of the histogram

Histogram Zoom Out Zoom out of the displayed period of time of the histogram

Marker I
If you want to export part of the recorded video clip, click 
to set marker I on the histogram, which will be the start 
time of the exported media

Marker II
If you want to export part of the recorded video clip, click 
to set marker II on the histogram, which will be the end 
time of the exported media

Export Media Click to export the marked video clip

Last Time Interval Go to the previous video clip on the video clips list

Last Frame Go to the previous video frame of the selected video clip

Pause Pause playback the selected video clip

Play Start to playback the selected video clip

Stop Stop to playback the selected video clip

Next Frame Go to the next video frame of the selected video clip

Next Time Interval Go to the next video clip on the video clips list

Repeat Mode Playback the selected video clip repeatly

Slow Down Slow down the playback rate

Speed Up Speed up the playback rate

Playback Timeline Slider

Playback Status PanelPlayback Control Buttons

Playback Histogram
(Displays the period of time of the 
video clip being played back)

Current time of the video clip
Total length of the histogram

The playback status 
(Stop/Playing)

The playing rate can be 1/8, 1/4, 1/2, 1X, 2X, 4X, 8X, 16X, 32X, and 64X�
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How to Playback Recorded Video

Select a Recorded Video Clip

Please follow the steps below to select a video clip:
1� On the Bowsing page, click the plus sign (+) to expand the hierarchical management tree� 

2� Right-click a station, device, or option “date” on the hierarchical management tree and click Refresh 
to display the recorded video clips� 

   

3� There are two ways to view the video clips of a date�
  View all video clips of a date:

a� Select a option “date” from the hierarchical management tree�
b� Double-click the option “date” or right-click the option “date” and click play, and it will start to 

play in an available video cell� (You can also directly drag-and-drop the option “date” to a desired 
video cell in the recorded video playback window� The video clip will start to play�)

a b
b
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  View only one of the video clips of a date:
a� Click a option “date” on the hierarchical management tree� The corresponding recorded video clips 

will be listed in the video clip list window�
b� Select a video clip from the video clip list window�
c� Double-click the video clip, then it will start to play in an available video cell� (You can also directly 

drag-and-drop the video clip to a desired video cell in the recorded video playback window� The 
video clip will start to play�)

4� Then you can make use of the playback control panel to playback the selected video clip� Please refer 
to Playback Control Panel on page 143�

a

b

c
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Remove Recorded Video Clips from Video Cells

There are two ways to remove a recorded video clip from the video cell: 
1� Right-click the video cell and select Remove�

2� Drag-and-drop the live view from the video cell to the hierarchical management tree window�

If you want to remove all live videos from the video cells, please click  on the menu bar�

Timeline Slider Bar and Histogram

The red part of the histogram shows the period of time of a video clip� The timeline slider bar will move 
forward as the video is on playback� You can manually move forward/backward the Timeline Slider Bar 
to the desired position as shown below� 

The current time of the video clip will be displayed on the status panel� It will change according to the 
current position of the timeline slider bar�

Start time of the histogram End time of the histogram
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Zoom in / out of the Histogram

As the second picture shows, by clicking Histogram Zoom In, the total time of the histogram will shorten 
to half of the original period of time, while the red part of the histogram that shows the period of time of 
the video clip will extend to twice the original time span�

In addition to clicking  and  to zoom in/ out of the histogram, you can use the mouse directly to 
drag the histogram to zoom in part of the focused video clip�
For example:
a� Drag a section of the histogram� You can drag it to either direction�

b� The section will be extended as shown below�

For more functions of the playback control buttons, please refer to page 143 for detailed description�

Histogram zoom in

Histogram zoom out

Total time length
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Synchronous Playback

VIVOTEK VAST Playback supports synchronous playback, which allows you to review up to 
16-channel video clips simultaneously during the specific time point.
Please follow the steps below to enable synchronous playback:
a� Drag-and-drop the option “date”s to the video cells�

b. Drag the Timeline Slider Bar to the specific time point.
c� Click the synchronous playback button 
b. Drag the Timeline Slider Bar to the specific time point.

 on the quick access bar� The selected channel will start to 
sychronously playback as shown below� 

b

c
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d� You can move forward/backward the Timeline Slider Bar to another time point, and all of the time 
stamps on the video cells will change accordingly�

e� If you want to stop synchronous playback, click the non-synchronous playback button  again�

The following illustration shows that during the specific time, there is no recorded video on the camera.
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Audio Control

The audio function will be enabled if the device is equipped with an internal or external 
microphone� Please follow the steps below to adjust the volume or turn on/off the audio of the 
focused video:
 To turn off the audio (Mute Mode)

a� Click Audio On  on the quick access bar and check Mute� Or you can right-click on the video 
cell to open the popup menu, then click Others > Mute� The mute option in the popup menu will then 
be selected�

b� If you want to turn off the audio of all live video, select Apply all� 
c� The Audio icon will then change from  to � 

 To adjust the audio volume
a� Click Audio On  on the quick access bar�
b� Drag-and-drop the slider bar� Slide to a higher position for louder volume�

 To turn on the audio
a� Click Mute  on the quick access bar and uncheck Mute� Or you can right-click on the video cell 

to open the popup menu, then click Others > Mute� The mute option in the popup menu will then be 
unchecked�

b� If you want to turn on the audio of all live video, select Apply all� 
c� The Audio icon will then change from  to � 

a b

a
b
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How to Change the Playback Layout

Changing the Layout of the Recorded Video Playback Window

VIVOTEK VAST Playback supports up to 16-CH simultaneous recorded video playback on a 
single monitor and allows you to change the layout of the recorded live video playback window 
based on the number of inserted devices� 

Switch Video Channels

Drag-and-drop a video channel to another empty video window�

To switch two channels, drag-and-drop one view to the other, then the two channels will switch 
positions�

Configure Layout Mode

Click the Layout button  on the quick access bar or click Layout > Change Layout on the menu bar� 
Select a desired layout mode and the layout window will change accordingly� Below we illustrate 6 types 
of layout modes:

Layout mode Description

1 x 1

2 x 2

1 + 5
3 x 3

1 + 12
4 x 4

 a video channel to another empty video window
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Maximize/Minimize the Recorded Video Playback Window

  Single View: to maxmize a video cell to the entire video playback window

Double-click the video cell, or right-click the video cell and selec Single View� The focused video will 
occupy the entire Playback window as shown below�

To restore to the original layout, double-click the video cell or right-click the video cell and uncheck 
Single View.
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 Full Screen: to maxmize the video playback window to the entire screen

Click Full Screen  on the quick access bar or right-click the video cell and select Full Screen� 
In addition, you can also click View > Full Screen on the menu bar to maximize the recorded video 
playback window� 

To restore to the original layout, right-click the video cell and uncheck Full Screen� You also can press 
the Esc button on the keyboard to leave the full screen mode�

  Minimize:  If you click View > Minimize on the menu bar, the Playback window will minimize 
   to the Windows tool bar�

View Recorded Video with Multiple Monitors

If you have multiple screens in your control center, you can switch the VAST Playback Window 
among these screens�

 If you have two monitors, click Switch Screen  on the menu bar, the Playback window of monitor 1 
will switch to monitor 2�

 If you have three or more monitors, a drop-down list will be displayed when you click Switch Screen 
 on the menu bar� The number of options on this list depends on the number of your screens� Select 

a desired screen from the drop-down list and the Playback Window will then switch to the specified 
screen�

Monitor 1 Monitor 2

Monitor 1
Monitor 2
Monitor 3
  ......
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How to Backup Recorded Video

In addition to the Schedule Backup function of VAST LiveClient introduced on page 61, the 
VAST Playback also features to backup recorded video clips from the local database� Please 
open the Browsing page and follow the steps below to backup recorded video:
a. Select the target files. 
  To backup all recorded video of a selected device: Right-click the device and click Backup�

  To backup all recorded video of the day: Right-click the option “date” and click Backup (or select the 
date and click the Backup button below)�
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  To backup part of the recorded video of the day: Select the date and choose the video clip(s) from 
video clip window� Then right-click the selected option(s) and click Backup� Note: Press Shift on your 
keyboard, then you can select more than one video clips�

b� A Backup Settings window will pop up� Specify the time span and select a storage path, then click 
Backup� The system will start to backup and popup a window showing the backup status�

   If you close the status window, you can also open it again by clicking View > Backup Status�

d� When the backup is complete, you will see an information dialog� The recorded data will be restored in 
the specific folder.
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How to View Backup Files

The VAST Playback also allows users to playback backup files, including Schedule Backup by 
VAST LiveClient and Recorded Data Backup by VAST Playback�

Please follow the steps below to view backup files:
a� Right-click Local DB and click Add�
b� A Load Backup File window will pop up as shown below� Select the *.dif file to upload�

c. The following is an example of uploaded file, and you can double-click it or drag-and-drop it to a 
video cell to playback�

a
b
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If you want to playback the backup files from the local database, you can also click Working Offline  in the Login 
Window without the account information� The VAST Playback will launch as shown below�

You can upload 
backup files

No user account information required
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How to Search for a Video Clip in a Specific Period of time

Please follow the steps below to use Time Search function:
a� Open the Time Search page�

b� Select the target station(s)/device(s) that you want to search for video clips�
c� Specify the time span� You can choose to set up the start time only, the end time only, or both the 

start time and end time� The search results will only include the video clips within the time span� If you 
uncheck both the start time and end time, the search results will include all video clips recorded by the 
selected device(s)�

d� Click Search to start time search�
e� View the retrieved video clips� 

Click here to move the focus to the current date 

Click to select a year
Click to select a month from the drop-down list

You can manually enter a specific time.

a

c

e

d

b
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How to Search for Events

The VAST Playback program offers users an intuitive event search engine for retrieving video 
clips from the database of recorded videos based on different search criteria such as motion, 
IVA, or DI events�    
Please follow the steps below to search for recorded events:
a� Open the Event Search page�

b� Select the target station(s)/device(s) that you want to search for events�
c� Specify the Event Category� For detailed information, please refer to Select Event Category on the 

next page�
d� Specify the time span for event search� You can choose to set up the start time only, the end time 

only, or both the start time and end time� The search results will only include the events within the time 
span� If you uncheck both the start time and end time, the search results will include all events from 
the selected device(s)� Please refer to step c� on the last page for detailed information�

e� Start event search� Please refer to page 163 for detailed information�
f� View the retrieved video clips� Double-click it or drag-and-drop it to the video cell� It will playback in 

repeat mode�
   Note: The length of each video clip will depend on your settings of pre-event time & post-event time for 

the recording storage� The default setting is 20 seconds� For more infromation, please refer to page 
68 for detailed illustration� 

b

c

d

e

f

a

repeat mode
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Select Event Category

The following introduces the event search categories: All Events, All Motion Events, All IVA 
events, All DI Events, Named DI Events, PIR, Tampering, and Tamperature� You can also 
add or remove customized events from the list� 

Event Category- All Events

If you select the All Events category, all of the events including motion detection, digital input, and 
intelligent video analysis, PIR, tamper detection, and tamperature alarm will be listed in the search 
results� You can click Add or Remove to change the search criteria options� 

Event Category- All Motion Events

If you select the All Motion Events category, all detected motion events will be included in the search� 
You can click Add or Remove to change the search criteria options�

The parameters of the motion detection windows, such as motion percentage and the time of occurrence 
are also recorded in the database of the server� If you wish to change the parameters of the motion 
detection windows such as the position, size, detection sensibility, and motion percentage, please link to 
the camera's Configuration page to modify the values.

Video(TCP-AV)
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Event Category- All IVA events

If you select the All IVA events category, all detected IVA events will be included in the search� Cameras 
with embedded intelligent video content analysis are capable of detecting IVA events such as moving 
objects, loitering, and tamper detection� 
The embedded video content analysis, superior to the conventional motion detection function, is capable 
of distinguishing between creature’s motions, static backgrounds or natural movements such swaying 
trees, waves or sunsets to prevent false alarms from environmental noises�
With camera tamper detection, it can detect incidents such as camera redirection, blocking or defocusing 
of cameras, or even spray-paint. Additionally, a suspicious object in the pre-defined detection region will 
trigger alarms once the dwell time of the object is longer than the given time� 
You can click Add or Remove to change the search criteria items�

If you want to change the parameters of IVA, such as the detection region, loitering duration, etc, please 
link to the camera's Configuration page to modify the values.

Event Category- All DI Events

If you select All DI Events category, all triggered DI signals will be included in the search� The DI events 
signify that there is a Digital-Input signal detected by the camera; its corresponding information such 
as DI-Trigger or DI-Normal signal and the time of occurrence are also transmitted and recorded in the 
database of the server� 
You can click Add or Remove to change the search criteria options�

For more information about DI/DO settings on the connected devices, please refer to page 49 for detailed 
illustration�
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Event Category- Named DI Events

This category allows you to select only Named DI Events--the DI device which you have renamed in 
the LiveClient� Please refer to Association Management on page 49 for more information about how to 
rename DI device�
Click OK and fill in the name you want to search on the left window.

The new search criteria will be displayed in the search categories column as shown below�
You can click Add or Remove to change the search criteria options�
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Start Event Search

After you specify all of the search criteria mentioned above, check/uncheck Display in new result list 
and click Search to begin event search�
  If Display in new result list is unchecked, all search results will be displayed on the original event list 

window as shown below�

  In the above picture, The Type field in the search result page shows the event category, and the 
Description field displays the motion percentage of the detection window� Please refer to page 160 
for more inforamtion about Motion Events�

  If you select Display in new result list and click Search, the search results will be displayed on a 
new page as shown below� This allows you to place the search results of each search category on an 
individual page� You can set up to 5 pages in the event list window�

Unchecked Only one page

Checked You can set up to 5 pages�
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Backup the Event Videos

Please follow the steps below to backup the evnet videos on the results list:
a� Select the video clips you want to backup� You can select more than one video clips�
b� Right-click the selected video clips and click Backup�

c� A Backup Settings window will pop up� For more information about how to set up the Backup 
Settings, please refer to page 154� For more information about how to view backup files, please refer 
to page 156 for detailed illustration�

a

b
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How to Search Logs

The VAST Playback program offers a convenient log engine for searching all local logs based 
on different search criteria such as log category, log type, and log level� The search results will 
be displayed in the log viewer window along with the detailed log history�

Please follow the steps below to search logs:
a� Open the Log Viewer page�
b� Select the target station where you want to search logs�
c� Specify the Log Category� For detailed information, please refer to Select Log Category on page 166�
d� Specify the User Account� If you have added other user accounts to the station, you can select one to 

search its login history� For detailed information about user account, please refer to How to Manage 
User Accounts on page 44�

e� Specify the Search Result� Select All to display all search results; select Success to display successful 
log activities only; select Fail to display failed log activities only� 

f� Specify the Log Type� For detailed information, please refer to Select Log Type on page 166�
g� Specify the Log Level� For detailed information, please refer to Select Log Level on page 166�
h� Specify the search time span� You can check the start time only, the end time only, or both the start 

time and end time� The search will only include the events within the time span� If you uncheck both 
the start time and end time, the search will include all events saved by the server� Please refer to page 
158 for detailed information�

i� Start the log search and the results will be displayed on the log list window� 

a

b

c

h

ed

i

i

f g
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Select Log Category/Log Type/Log Level

The following table shows the breakdown of log category, level, and type� The search results will 
be different according to your selections�
Log Categories Log Levels Log Types

Operation Log

Normal

Login / Logout
Insert User
Update User Name
Update User Password
Update User Privilege
Delete User
Insert Station
Update Station Information
Update Station Name
Delete Station
Insert Camera
Update Camera Information
Delete Camera
Set Recording Group
Insert Recording Schedule / Update Recording Schedule / Delete Recording 
Schedule
Insert Event Management / Update Event Management / Delete Event 
Management
Insert Recording Group / Update Recording Group / Delete Recording Group
Insert Recording Path / Update Recording Path / Delete Recording Path
Insert Camera to the Recording Group
Update Camera information in the Recording Group
Delete Camera from the Recording Group
Move Recording Path
Move Camera to another Recording Group
Insert Layout / Update Layout / Delete Layout
Set Digital Output
Update Scheduled Backup 
Update Server Port                      
Set Proxy Server
Set UPNP
Set DDNS Server
Create Directory / Rename Directory / Delete Directory                            
Insert SMTP Server / Update SMTP Server / Delete SMTP Server
Insert Network Storage Device / Update Network Storage Device / Delete Network 
Storage Device
Set GSM Modem
Set DI/DO Rename
Set Relay Settings
Update License Information
Update Web Access Information
Insert Matrix Recipient / Insert Matrix Recipient Information / Delete Matrix 
Recipient 

High Manually Begin Recording
Manually Stop Recording

Low
Camera PTZ, Iris, Focus, Pan, Patrol Control
Click on Image
Select Preset Location

System Log High

Server Start / Server Stop
Trial Expired
Key Dongle Lost
Virtual Memory Low
Network Lost
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Search All Local Logs

Search Login History

Select Login History from the log category field and click the Search button below, the search results, 
including all login logs, will be displayed on the Login History page�

Log Categories Log Levels Log Types

Event Log High

Camera Disconnected from the Server / Camera Connected to the Server
Parent Station Connection Lost / Parent Station Connection Restore
Sub-station Disconnected / Sub-station Connected
Camera Recording Start / Camera Recording Stop 
Start Scheduled Backup / Stop Scheduled Backup 
Event Trigger

Log Level
Log Category

Log Type

Click to remove all search results from the list
Click to export all search results from the list
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Search Login Activities

This function allows you to search the operations the user performed during the login period of time� You 
can search for login activities on the Local Logs or Login History page�

  Search Login Activities on the Local Logs page:
a� Click on the Local Logs page�
b� Select a login/logout option from the list�
c� Click Trace Login Activities (or you can right-click the selected login/logout option on the list, then 

click Trace Login Activities)�

d� The search results of the login activities will be displayed on the Login Activities page as shown below�

  Search Login Activities on the Login History page:
a� Click on the Login History page�
b� Select a login/logout option from the list�
c� Click Trace Login Activities (or you can right-click the selected login/logout item on the list and 

click Trace Login Activities)�

a

b

c

c

a

b

c

c
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d� The search results of the login activities will be displayed on the Login Activities page as shown below�

When you select All  in the Log Level  field, the search results will include all log levels. If you select Low in the 
Log Level  field and select Including above level  as shown in the picture on the left below, the search results 
will include all levels of logs� But if you select Normal  in the Log Level  field and select Including above level  as 
shown in the picture on the right below, the search results will only include Normal-level  and High-level logs�
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How to Configure Client Settings
On Client Settings, you can configure Snapshot Settings, Export Settings, View Settings, Proxy 
Settings, and General Settings� It allows you to save snapshots and media files on the local 
computer� 

Snapshot Settings

When you play a recorded video, VAST Playback also allows you to take snapshots� For 
detailed information about Snapshot Settings, please refer to page 106�

Export Settings

When you playback a recorded video, the VAST server allows you to export part of the recorded 
video in EXE, 3GP, or AVI format to your local computer. Before exporting a media file, please 
set up Export Settings first� For detailed information about how to set up EXE, 3GP, and AVI 
Export Settings, please refer to Record Settings on page 108� 
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Export an EXE/3GP/AVI File

Please follow the steps below to convert part of an EXE/3GP/AVI file of recorded video:
a. Playback a video clip from which you want to export a media file.
b� Set a period of time� Move the timeline slider bar to the desired start time and click Marker I � Move 

the timeline slider bar to the desired end time and click Marker II �

c� Click Export EXE/3GP/AVI , the server will start to export the data and popup a window showing 
the exporting status� If you close the status window, you can also open it again by clicking View > 
Exporting Status� 

d� When the backup is complete, you will see an information dialog� The exported data will be restored 
in the preset storage folder on your local computer (C:\Program Files\VIVOTEK Inc\VAST\Client\
Playback\Export).

a

b

c

d

c c
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View Settings

This section allows you to set up the display mode of video cell� For detailed information about 
View Settings, please refer to page 114�

Proxy Settings

Please refer to page 122 for detailed illustration�

General Settings

System Settings
Please refer to page 116 for detailed information�

Display Settings
  Enable de-interlace function: Select this option if your connected device does not support de-interlace 

function� For example: VS7100�

How to Configure Video Enhancement

The Playback also allows you to enable post-image enhancement and defog for video viewing� 
Please refer to page 126 for detailed information�

How to Search for a Device on the Hierarchical Management Tree

The Playback also allows allows you to conveniently search for an inserted device� Please refer 
to page 131 for detailed information�

How to Print a Video Image

The Playback also allows you print out an image of live video� Please refer to page 132 for 
detailed information�
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How to Lock VAST Playback for Security Concerns

If you happen to be away from your computer, for security reasons, we suggest you lock the 
program� When VAST Playback is locked, the user must enter the correct password to unlock 
and access the program again�
 To lock Playback, click Unlock  on the quick access bar or click System > Lock on the system 

menu� The Unlock  icon will then turn into Lock � 
 To unlock Playback, click  and enter the correct password in the popup window�

How to Log out from the VAST Server

To log out from the current server, click the station and click Logout  on the quick access 
bar or click System > Logout on the menu bar� You can also right-click the station and click 
Logout. A confirmation window will pop up. Click OK to confirm or Cancel to return to the VAST 
Playback window�

How to Exit VAST Playback

To exit VAST Playback, click Exit  on the quick access bar or click System > Exit on the 
menu bar� A confirmation window will pop up� Click OK to confirm or Cancel to return to the 
VAST Playback window� When you exit the program, your user account will be automatically 
logged out from the current server�
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Import and Export Utility

VAST supports import and export utility for user to keep record of all server settings� You can 
use the export file to copy the configuration on another host.

Export Utility
Please follow the steps below to export the server settings:
a� Under Microsoft Windows, choose "Start > All Programs > VIVOTEK Inc > VAST > Tools > Import-

export Utility."

b� The Import/Export Utility window will pop up� Click Export and select a target folder� The system will 
start to export a .bin file.

Import Utility

Please follow the steps below to import the server settings:
a� Under Microsoft Windows, choose "Start > All Programs > VIVOTEK Inc > VAST > Tools > Import-

export Utility."
b� The Import/Export Utility window will pop up� Click Import and select the export file. The system will 

start to import the file.
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VAST Service Control Tool

VAST service control tool is a tool for server control and for user to be aware of the VAST Server status� 
It starts up as Windows OS startup�
Under Microsoft Windows, choose "Start > All Programs > VIVOTEK Inc > VAST > Tools > 
VNSServiceControl."

You may also find it in the system tray icon of the tool bar, which indicates that the service is running: 
 
It shows a disconnection icon when the service is stopped: 

A menu for the service control tool will pop up when you right-click on the icon: 

Here you can manually start, stop and restart the service�




